Node-webkit export OSX app doesn't work

Discussion and feedback on Construct 2

Post » Tue Apr 02, 2013 7:38 pm

Hi, i have exporter my app, for pc-mac-linux
my app just play videos "webm"

The pc version "EXE" works fine.
But the mac version "DMG" dont work at all, do i have to make something special???

no one can help with this? it is a solution when i export in Node-Webkit for pc and Mac???

Pc version works perfectly but the Mac version DMG don't work at allAshley2013-04-02 19:59:45
B
32
S
9
G
6
Posts: 1,470
Reputation: 7,957

Post » Tue Apr 02, 2013 7:59 pm

What do you mean by "doesn't work"? Can you explain exactly what happens?

P.s. edited your title to be lowercase, since all uppercase can be considered shouting/rude online.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Tue Apr 02, 2013 8:10 pm

the dmg dont start at all, and it's without error messages, whe tried with 3 mac at the office, and the DMG app don't work.imothep852013-04-02 20:54:22
B
32
S
9
G
6
Posts: 1,470
Reputation: 7,957

Post » Tue Apr 02, 2013 9:13 pm

Did you try making a simple test program to see if it works? If it does work, then it would narrow it down because you know it what is not the problem.
If it doesn't work you could post it here for others to test and see if it works for them. If it doesn't work, they may be able to point out what is wrong.
B
201
S
52
G
30
Posts: 897
Reputation: 36,621

Post » Tue Apr 02, 2013 9:19 pm

How are you playing the videos? Construct 2 doesn't have any built-in video playing features, and if you're using a third party plugin, the plugin could be causing the problem.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Tue Apr 02, 2013 9:37 pm

well....i use this video plugin http://www.scirra.com/forum/plugin-video_topic46310.html

and iplay webm videos

When i compile the app with node-webkit it work perfectly on pc and on mac that dont run at all

when i open the Info.plist i found this

<key>LSMinimumSystemVersion</key>
     <string>10.6.0</string>

in my office we have Macs osx with 10.8.0 versions so its not our osx systems.



B
32
S
9
G
6
Posts: 1,470
Reputation: 7,957

Post » Tue Apr 02, 2013 10:00 pm

This happens for me also, with no unofficial plugins at all.
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400

Post » Tue Apr 02, 2013 10:08 pm

Well its a problem if Ashley or others official creators, can't create or no have time for developping a Video plugin, its a big problem.
i have to develop multimedia apps, for pc-mac-linux who use videos and interactive objects like buttons.

it is a solution???
B
32
S
9
G
6
Posts: 1,470
Reputation: 7,957

Post » Tue Apr 02, 2013 10:11 pm

@imothep85 I don't think it's the video plugin as my project also had the same problem on a mac.
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400

Post » Tue Apr 02, 2013 10:14 pm

thats what im thinking too, under pc my app works fine, that means if the compiled app works on pc, its no reason for the app not working under osx.

and the webm its a standard video format now, used in almost every platform, like vimeo,youtube etc etc.
on pc and mac webm videos can be read with vlc without problemimothep852013-04-02 22:14:37
B
32
S
9
G
6
Posts: 1,470
Reputation: 7,957

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests