node-webkit game+savegames?

Discussion and feedback on Construct 2

Post » Sun Apr 27, 2014 5:22 pm

Hi everybody :)
any chance to export a game with savegames using the node-webkit tool?

thank you in advance :)
B
10
S
2
Posts: 19
Reputation: 698

Post » Sun Apr 27, 2014 5:55 pm

bkdove wrote:Hi everybody :)
any chance to export a game with savegames using the node-webkit tool?

thank you in advance :)


What do you mean? I thought you can savegame in NK?
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
92
S
30
G
22
Posts: 1,987
Reputation: 20,178

Post » Sun Apr 27, 2014 6:24 pm

Yes, loading and saving with node-webkit.
I'm testing the prototype on some different PCs but the result is the same:
My game has one savegame (keeping the player status, the hiscore and the game stats) that loads on startup. When I export the project with node-webkit the game doesn't start (it freezes on the load page). If I export the game without the save/load actions, it works properly.
Any solution?
B
10
S
2
Posts: 19
Reputation: 698

Post » Sun Apr 27, 2014 6:28 pm

bkdove wrote:Yes, loading and saving with node-webkit.
I'm testing the prototype on some different PCs but the result is the same:
My game has one savegame (keeping the player status, the hiscore and the game stats) that loads on startup. When I export the project with node-webkit the game doesn't start (it freezes on the load page). If I export the game without the save/load actions, it works properly.
Any solution?


Don't know. Sorry :/
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
92
S
30
G
22
Posts: 1,987
Reputation: 20,178

Post » Sun Apr 27, 2014 6:44 pm

How are you implementing saving and loading?
Never had any issue with node-webkit and save/load using System actions or webstorage or any others
ImageImageImageImage
B
158
S
67
G
43
Posts: 2,603
Reputation: 35,968

Post » Sun Apr 27, 2014 7:14 pm

SImply using system actions. The problem does not appear on my PC but only when I try to open the exported gamefile on different PCs with windows 7.
B
10
S
2
Posts: 19
Reputation: 698

Post » Sun Apr 27, 2014 7:33 pm

You are probably on start of the layout try to load a game state that doesn't exist. That would explained why it works only on your pc.
ImageImageImageImage
B
158
S
67
G
43
Posts: 2,603
Reputation: 35,968

Post » Sun Apr 27, 2014 7:57 pm

how can I make sure that a game state exists in the exported file?
I am pretty sure that the game is saved because it keeps the global variables after a restart and the load action.
B
10
S
2
Posts: 19
Reputation: 698

Post » Mon Apr 28, 2014 8:43 am

shinkan wrote:You are probably on start of the layout try to load a game state that doesn't exist. That would explained why it works only on your pc.

you were right, I checked this morning. the problem is solved by adding the "onloadfailed" action on the startup. after the first start it works properly. thank you!
B
10
S
2
Posts: 19
Reputation: 698

Post » Mon Apr 28, 2014 8:50 am

Good to know.
Also if you want to get someones attention use @ befor nick like @shinkan because I completely missed your last question.
But I'm glad you sorted it out yourself.
ImageImageImageImage
B
158
S
67
G
43
Posts: 2,603
Reputation: 35,968

Next

Return to Construct 2 General

Who is online

Users browsing this forum: AlexiarTW and 9 guests