Node Webkit Jerkiness partial workaround.

Bugs will be moved here once resolved.

Post » Sun Feb 01, 2015 9:50 pm

So I was messing around on a low end machine that I have for emulation last night (3ghz, 3gb ram, 730gt gfx Win 7-64-bit) and our game was running like absolute garbage, a total stuttering mess. I was at a bit of a loss because I have a far worse machine that ran the game way better. Since there is nothing else running on the machine and I knew the drivers were all up to date, I decided to go set nVidia profile up for the game just for the hell of it.

Anioptropic filtering OFF
Antialiasing FXAA OFF
Antialiasing MODE OFF
Antialiasing Setting None
Antialisasing Transparency OFF
CUDA - GPUs ALL
MAX Pre-Rendered Frames 4
Muilt-Display/Mixed-GPU Acceleration MULTI DISPLAY PERFORMANCE MODE
Power management mode PREFER MAXIMUM PERFORMANCE
Shader Cache OFF
Texture Filtering Anisotropic Sample Opti. OFF
Texture Filtering - Negative LOD BIAS ALLOW
Texture Filtering - Quality HIGH PERFORMANCE
Texture Filtering - Trilinear Optimization OFF
Threaded Optimization OFF
Triple Buffering OFF
Vertical Sync OFF
Virtual Reality Pre-Rendered Frames 4

Although I still got a bit of stutter - it's not a gaming rig period. It's single core, low profile cheap stuff. And the game was running almost perfectly. Before that it was completely unplayable.

So there's that... Let me know if this helps any of you :)

DMM

***EDIT***
After I posted this, I did a play through of the 2nd half of our game. Playing on my build laptop since I was fixing a bug. I had zero jerkiness/jankiness. We're also using NWK 10.5 for our steam build. The last stage of the game *always* had a bit of jank to it, but this time through it was flawless 60fps. I even played through it again just to make sure I wasn't crazy and this level is deadly hard too!! Hopefully this fixes the issue for some people. I'm assuming it would be similar for Radeon cards etc.
B
47
S
12
G
7
Posts: 341
Reputation: 7,953

Post » Tue Feb 03, 2015 3:36 pm

Closing as this is not a bug report.

The only significant change is probably that you turned off v-sync, so it's rendering probably hundreds of frames per second, hiding any scheduling timing errors.
Scirra Founder
B
395
S
232
G
88
Posts: 24,368
Reputation: 193,746

Post » Tue Feb 03, 2015 8:56 pm

It may not be a bug report, but it is helpful, can this be stickied somewhere or in a FAQ of suggestions for games to run faster?
"Construct 4 lets YOU make advanced games! (but not play them)" Construct Classic - Examples Kit Dropbox is a pile of trash and if you need my old files PM me! :)
B
116
S
41
G
17
Posts: 2,202
Reputation: 19,541


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest