Node webkit preview works export crashes on specific layout

Discussion and feedback on Construct 2

Post » Sun Dec 14, 2014 3:15 am

Hello, can anyone help me out on this?

Node webkit preview works 100% fine for the whole of my project (many layouts)
but when I export it crashes on one specific layout (the main game). I get this error.

Uncaught node.js Error

SyntaxError: Unexpected end of input
at Object.parse (native)


I don't understand why the preview works (it works in node webkit preview, chrome and firefox with no problems)
it only breaks once I export it. Any ideas? Why would the previews all work, but the export not?
B
33
S
8
G
1
Posts: 39
Reputation: 2,297

Post » Sun Dec 14, 2014 6:43 am

Are you using any custom plugins? Some custom plugins aren't minify compliant, and will break when exported.

Try exporting without minification.
Don't lose your work. Backup your game with Dropbox.
B
44
S
10
G
10
Posts: 1,106
Reputation: 9,187

Post » Mon Dec 15, 2014 3:41 am

Unfortunately that's not it, even without minification it causes this error
B
33
S
8
G
1
Posts: 39
Reputation: 2,297

Post » Mon Dec 15, 2014 4:19 am

Just want to follow up, the problem is a broken Spriter file. It`s very strange as all other Spriter files seem to be working fine, but one somehow become corrupted (?) anyway, by deleting it, it exports fine. Good lesson to learn though for anyone who gets random node.js Errors on export - start by one by one deleting their spriter SCON files and see if they cause the problem.
B
33
S
8
G
1
Posts: 39
Reputation: 2,297

Post » Mon Dec 15, 2014 4:20 am

Still not sure why it would work fine on preview and not export though.
B
33
S
8
G
1
Posts: 39
Reputation: 2,297


Return to Construct 2 General

Who is online

Users browsing this forum: RoboticPhoenix and 5 guests