Non-standard resolution woes.

Discussion and feedback on Construct 2

Post » Thu Jan 16, 2014 2:26 am

One of my biggest gripes when wanting to make a game that isn't 720p or higher, but closer to retro resolutions, but still in 16:9, is finding a resolution that fits and works.

I was testing some dialogue stuff (mostly just menu graphics and positioning, to see how it looked visually) and had settled on 768x432, using this list I found: http://pacoup.com/2011/06/12/list-of-true-169-resolutions/ (better than calculating the resolution every time you do something).

However, when I run the project the image wasn't stretched to the edges and had huge black borders around it. I tried every scaling mode and switched the browser(I mostly use webbkit, but it performed the same in chrome). No dice.

So I load up an example and change the resolution to 1280x720 at first, same deal. Poke about a bit, and suddenly it works as it should. Switched it to my desired resolution of 768x432, and it worked as it should. I have no idea why this is.

Not submitting this in the bug section because I'm not convinced it's a bug.

My test file:
https://dl.dropboxusercontent.com/u/22615804/lia-diag-test.capx

The example I tried:
https://dl.dropboxusercontent.com/u/22615804/platformer-example-768x432.capx

EDIT: After some sleep I returned to the issue and took another look. I was using the browser object to request fullscreen and it doesn't seem like the request fullscreen action actually changes the scaling mode.inkBot2014-01-16 08:16:01
B
73
S
20
G
10
Posts: 524
Reputation: 9,896

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests