[NOT SOLVED] Simulate latency.

Just started using Construct 2? Post your questions here

Post » Tue Dec 22, 2015 10:23 am

Hello, a question about the object and multiplayer action "simulate latency".

If you use this action in the example "real-time game," players sometimes disappear and reappear in the position in which they were located.

I would like to know what's going exactly, does the player is disconnected and reconnected ?.
Why your graph disappears and then reappears ?.
B
28
S
11
G
20
Posts: 729
Reputation: 13,674

Post » Thu Dec 24, 2015 2:00 pm

Nobody has an answer?
Could the moderators move this question to some other section where someone can help me ?.
B
28
S
11
G
20
Posts: 729
Reputation: 13,674

Post » Thu Dec 24, 2015 2:07 pm

I guess your answer would be much easier to answer if you would either share your events or the capx..

Like the manual explains, simulate latency should only be added to the host when testing local, since that guarantees every message in the game will have delay added..
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Thu Dec 24, 2015 4:22 pm

I saw it in the documentation.
I think I'm doing well.

Image

What I do not understand is that the players disappear and appear, sometimes appear when I press a button and others automatically appear.

https://dl.dropboxusercontent.com/u/60803633/test.capx
B
28
S
11
G
20
Posts: 729
Reputation: 13,674

Post » Thu Dec 24, 2015 9:28 pm

Hello again, here is a very clear example of what happens.

Notice how increases the value of the variable "ReconnectsPEER" in the peer group.

Each time the PEER graph disappears and reappears, this variable increases its value and "On created" is True again.

I have problems in my game because of this and ask you please if anyone can check it, it does not seem normal to the graph of PEER disappears.

HOST graph disappears often.

Tests I've done have been on the same PC with two different browsers.
Normally you only have to wait one minute or less to occur.

https://dl.dropboxusercontent.com/u/60803633/test2.capx

Please @Ashley or @zenox98, May review this?.
B
28
S
11
G
20
Posts: 729
Reputation: 13,674

Post » Sun Dec 27, 2015 9:58 pm

Please, anyone can check this ?.

Is it necessary "on created" is true whenever the sprite reappears?

Is this normal ?, is it a bug ?, I have to adapt my game to this situation or is an error that must be corrected in multiplayer object?.

I really do not understand, what should I do when the sprite disappears? Is there any way to figure out when is this happening ?.
B
28
S
11
G
20
Posts: 729
Reputation: 13,674


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 1 guest