Nova Break (updated 4/26/2014)

Show us your works in progress and request feedback

Post » Sun Mar 09, 2014 4:32 pm

Click here to play the new demo: http://www.dthomasdigital.com/novabreak/index9.html

Introduced a bug in yesterdays demo update so we needed to fix it and fixed a few others as well.

To play the latest version of Nova Break click HERE!

Bug Fix:

- fixed not being able to fire on player warping in after being killed
- music not stopping when leaving the how to play screen
- bomb no longer appearing on top of other objects

Thanks for playing – dthomasdigital
Last edited by dthomasdigital on Sun Apr 27, 2014 12:21 am, edited 14 times in total.
B
25
S
10
G
3
Posts: 154
Reputation: 2,843

Post » Sun Mar 09, 2014 11:49 pm

well it doesn´t open here...not even a loading screen. :)
Image
Check out our start-up and configure your own helmet in true 3D.
B
44
S
11
G
11
Posts: 1,154
Reputation: 9,978

Post » Mon Mar 10, 2014 12:18 am

Reload and try again I found a bit of a bug, let me know, it might be me trying to embed all the fonts too, so switching over to sprite fonts. I've tested it mostly with chrome so let me know if you using something else.
B
25
S
10
G
3
Posts: 154
Reputation: 2,843

Post » Mon Mar 10, 2014 6:11 am

Wow this look FANTASTIC!! The style is so 70's I want to say for some reason. Great developer studio intro :D. I am using Chrome and it ran smoothly for me.

I tested in IE 11 for you and the most I got was a quick glimpse of the load icon then it went black. I waited 2 min it didn't load at all :|.
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Post » Mon Mar 10, 2014 12:24 pm

Thank you for the input, I've done lots of font embedding, pre-loading sounds and stuff like that. All that might be causing things to go belly up, plus way to much webgl effects so I need to look at some optimization, and of course some real sloppy code that needs to be cleaned up. I'll be posting almost daily updates to the demo and posting the updates logs to http://www.dthomasdigital.com. anyone check it on Firefox yet, I pulled it up on the wiiu and well it loaded and looked mighty slow and funny (that's funny in a bad/sad way).
B
25
S
10
G
3
Posts: 154
Reputation: 2,843

Post » Tue Mar 11, 2014 2:49 am

Even being in 2D, I feel to be playing in 3D arcade type machines.
B
17
S
1
Posts: 89
Reputation: 1,259

Post » Tue Mar 11, 2014 4:00 am

It was interesting, I'm using Firefox:

- logo splash of your company is 3 times too long (takes about 10 sec on my side)

- I didn't like to have to input my name to start playing
- I thought for quite some time that I was the ship in the middle, maybe make it appear after me would help to clarify
- I didn't know the controls, I clicked to start the game, so I assumed I was playing with mouse, took me some time to realise I have to let go the mouse to play with arrows and space

- graphics are very cool, love them
- I would love to have a black & white version, and maybe some old CRT screen effects ^^
- the welcome back and input name fields have a different font than everything else, and it's not a nice one
- I think all the icons on top and level selection should have the same kind of very thin line than the game has. And no rounds, just some polygonal circles like the ones around the middle ship

- when I resumed playing the second time, the game recognized my name, but I can't click on any level on the level selection screen (even level 1 is locked)
- when I finished the first level, the game showed me I completed both level 1 & 2 with 2 stars, level 3 was available
- after finishing level 3, my mouse disappeared, cannot click the 'next' button
...but this is mostly psychological.
B
17
S
5
G
3
Posts: 262
Reputation: 3,008

Post » Tue Mar 11, 2014 12:52 pm

Fantastic feedback sved, all ready working on many of your points, again thanks this was exactly what I was hoping for by posting the game in such an early stage of development, thanks to all for helping.
B
25
S
10
G
3
Posts: 154
Reputation: 2,843

Post » Tue Mar 11, 2014 3:34 pm

Well, I have always been fond of asteroids and it's clones, and have played a lot of pewpew. So I think you have it going very well here. Only a couple things I might argue: company logo stays too long (if you are loading sounds here, try to include sth like "Loading" somewhere on the screen) and screen transitions are just a tad slow. I liked the menu design and movement bewteen them, interface seems very well done. Hope you keep working on this.
B
18
S
4
G
1
Posts: 332
Reputation: 3,149

Post » Tue Mar 11, 2014 4:21 pm

Thanks, all this feedback really helps, I agree my loading screen needs some real work I like it for the effect but I agree it's way to long and it needs some work. Expect some real improvements as I take this feedback and implement the changes....
B
25
S
10
G
3
Posts: 154
Reputation: 2,843

Next

Return to Works in Progress/Feedback Requests

Who is online

Users browsing this forum: gamecorpstudio and 3 guests