NW.js Plugin Broken In Preview (v0.27.0)

Bugs will be moved here once resolved.

Post » Fri Dec 08, 2017 4:05 pm

Problem Description
The most recent stable release of NW.js (v0.27.0) gives a JS error message on startup caused by the NWjs plugin.

Attach a Capx
Blank project with the added NW.js plugin.

Steps to Reproduce Bug
  • Create new blank project
  • Add the NW.js Plugin
  • Preview using NW.js v0.27.0

Observed Result
Construct 2 displays the following error message when starting preview:
Code: Select all
Javascript error! Uncaught TypeError: Cannot set property 'onchange' of nullhttp://192.168.2.120:50000/NodeWebkit_plugin.js, line 90 (col 35)

Console says the following:
Code: Select all
Uncaught TypeError: Cannot set property 'onchange' of null
    at pluginProto.Instance.instanceProto.onCreate (NodeWebkit_plugin.js:90)
    at Runtime.loadProject (preview.js:1482)
    at XMLHttpRequest.xhr.onload (preview.js:414)


Expected Result
It should preview games just like it did in the previous versions.

Affected Browsers
  • NW.js (YES)
  • Chrome: (NO)
  • FireFox: (NO)
  • Internet Explorer: (NO)

Operating System and Service Pack
Win7 SP1, up to date drivers.

Construct 2 Version ID
r249 (beta)
ImageImageImage
B
81
S
30
G
78
Posts: 752
Reputation: 46,393

Post » Mon Dec 11, 2017 12:13 pm

It looks like a bug in the NW.js 0.27 update. I don't think we can work around this, but hopefully it's straightforward and the next NW.js update can fix this. Filed an issue here: https://github.com/nwjs/nw.js/issues/6321
Scirra Founder
B
414
S
245
G
92
Posts: 25,188
Reputation: 200,307

Post » Mon Dec 11, 2017 2:11 pm

Thanks for the report, I hope this will be backported to all older versions as well.
ImageImageImage
B
81
S
30
G
78
Posts: 752
Reputation: 46,393

Post » Mon Dec 11, 2017 3:54 pm

As far as I'm aware, only NW.js 0.27 is affected, and the issue is in NW.js itself so we don't need to change C2 when it's fixed, just issue a new NW.js update.
Scirra Founder
B
414
S
245
G
92
Posts: 25,188
Reputation: 200,307

Post » Mon Dec 11, 2017 4:02 pm

Does this mean that nwjs 0.27 will be dropped from the list? By backporting I basically meant backported into that specific version.
(Nevermind you've already asked the question, will subscribe and wait for their response.)
ImageImageImage
B
81
S
30
G
78
Posts: 752
Reputation: 46,393

Post » Mon Dec 11, 2017 6:15 pm

Uninstalled 0.27.0 and used v0.26.0 and all is good.
B
29
S
5
Posts: 19
Reputation: 1,960

Post » Fri Dec 15, 2017 12:56 pm

Just released NW.js 0.27.2 which should fix this. Can you confirm?
Scirra Founder
B
414
S
245
G
92
Posts: 25,188
Reputation: 200,307

Post » Fri Dec 15, 2017 2:15 pm

Ashley wrote:Just released NW.js 0.27.2 which should fix this. Can you confirm?

Yep everything is alright now, preview works as intended. This bugreport can be closed.

If this didn't get backported into v0.27.0, I'd recommend removing it from the downloads page.
Would make things easier for people that don't know about this issue. Thanks for doing all the reporting work!
ImageImageImage
B
81
S
30
G
78
Posts: 752
Reputation: 46,393


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest