NW.js crashes video card

Discussion and feedback on Construct 2

Post » Sun Aug 27, 2017 11:53 pm

Every once in a while, seemingly at random, my video card will crash and I seldom get the following error message just when NW.js loads, but usually it crashes my video card after my game fully loads and then I get no error message.

https://1drv.ms/i/s!Ak5NmenBvuyPjRxuRpQirzmNIwjo
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Post » Tue Aug 29, 2017 6:20 pm

I wouldn't care so much, except it causes C2 to freeze up when it happens and I lose all my work if I hadn't saved. Which, due to the random nature of it, I have to save every 2 seconds.
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Post » Tue Aug 29, 2017 6:26 pm

Probably best if you can provide a simple .capx that we can all try. At least then we can determine if it is C2, NW.js or GPU/driver related.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,419
Reputation: 59,524

Post » Tue Aug 29, 2017 6:54 pm

@corlenbelspar

This is more likely an issue with your GPU driver or Chrome/NW.js than something with C2 or C3. I've had it happen randomly, usually in preview w/ C2, but I've also had it happen with YouTube. Updating/reinstalling drivers or restarting my PC hasn't failed me yet.
B
80
S
46
G
24
Posts: 525
Reputation: 20,955

Post » Tue Aug 29, 2017 8:50 pm

I think it's maybe to do with webGL, but I wasn't sure. I can try reinstalling my drivers, but that didn't seem to fix anything, but then Windows Update is possessive about updating them and that always screws them up somehow.
B
45
S
13
G
1
Posts: 236
Reputation: 4,010


Return to Construct 2 General

Who is online

Users browsing this forum: Yahoo [Bot] and 15 guests