nwjs export and preview build performance difference

Bugs will be moved here once resolved.

Post » Sun Sep 18, 2016 3:27 am

Talked about earlier here:
viewtopic.php?f=146&t=170362

Problem Description
Final export builds have visible jank on Windows whereas preview builds don't. Gets a lot worse with nwjs 17.0 than 16 and earlier.

Attach a Capx
@Ashley I'd rather not post the capx out in the open so can I PM the link to you?
Description of Capx
Stripped down version of game in progress, starts in a test level where jank is evident by just moving around and letting the camera scroll back and forth.
Steps to Reproduce Bug
  • Step 1
    Run the capx on a computer with Intel Iris 6100 or similar.
  • Step 2
    Observe scrolling speed during preview. Double-tap direction key to move around faster.
  • Step 3
    Export and compare export screen updating to that of preview.

Observed Result
Janky as all hell on export with nwjs 17.0, visible jank on 16.0 and earlier.

Expected Result
That export builds run as smooth as, if not smoother than, preview.

Affected Browsers
nwjs

Operating System and Service Pack
Windows 8.1

Construct 2 Version ID
r232 - earlier versions have been behaving exactly the same.
B
39
S
16
G
6
Posts: 542
Reputation: 7,617

Post » Mon Sep 19, 2016 10:31 am

Please reproduce the problem in a new .capx and post if at all possible as per the bug report guidelines.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,600

Post » Mon Sep 19, 2016 10:50 am

Sorry, I simply don't have the time for that. That'd be x amount of hours doing complete stabs in the dark for something I may not even be able to reproduce, me not knowing the inner workings of C2 or how it bundles export builds. Reading the nwjs blog, it seems they've done some extensive re-writing to how garbage collection is handled, which leads me to believe it's related to that. But again, I'm not a tech person nor do I know how C2 really works under the hood.
B
39
S
16
G
6
Posts: 542
Reputation: 7,617

Post » Fri Sep 23, 2016 12:57 pm

Closing as this bug report isn't useful like this, if you really want me to look in to it you can email the project to [email protected] but you might have better luck reporting it to NW.js directly. I can't think of any reason preview and export would perform differently, if anything export should be faster.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,600

Post » Fri Sep 23, 2016 3:26 pm

@Ashley: I just discovered the fix was completely trivial. I had kiosk mode turned on, and that's what caused all the stuttering for some reason. Now that I turned it back off it performs the same as preview. So, still a bug I guess? But easy to get around at least. Thanks for offering though.
B
39
S
16
G
6
Posts: 542
Reputation: 7,617


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest