NWJS not completely closing when exiting app

Bugs will be moved here once resolved.

Post » Mon Jan 18, 2016 3:57 am

Windows 7 x64 and non-Steam Construct 2 here: Neither exports nor previews NW.js projects. For example the Savegames Tutorial project works fine. The ghostShooter tutorial does not. A totally empty New project also doesn't work!

I cannot open the exported .exe files or preview, and NW.js *32 stays open in the task manager, hanging without opening a window like FraktalZero. Usually it's two instances of the NW.exe

I've tried every version of nw.js after 0.12, but 0.12 is the last one that works. Seems the newer ones are completely broken for me
B
25
S
11
G
4
Posts: 191
Reputation: 4,402

Post » Mon Jan 18, 2016 7:03 pm

Just tried 122 preview still gets the ghost nwjs after first run.
Maybe it's time to try out Electron @Ashley ?
At least not have all our eggs in one basket.
Image ImageImage
B
164
S
49
G
138
Posts: 7,962
Reputation: 91,890

Post » Mon Jan 18, 2016 10:22 pm

NW.js 0.13.0-beta4 is out now, is that still affected?
Scirra Founder
B
378
S
220
G
84
Posts: 23,868
Reputation: 188,111

Post » Mon Jan 18, 2016 10:33 pm

@Ashley, sadly I still have the same problems with my project. Like in the previous version, I can perfectly test using a new project. So for now me I'm transferring everything into a new project.

@newt Theres also Tint. Now, I suppose the only way this could be done would be by another programmer. I would gladly pay for better exporting options for PC.
B
39
S
10
G
14
Posts: 488
Reputation: 10,270

Post » Mon Jan 18, 2016 10:54 pm

Ashley wrote:NW.js 0.13.0-beta4 is out now, is that still affected?


Just tried it.
Same thing.
No change.

@FraktalZero
Dunno Tint looks it's not quite there.
Image ImageImage
B
164
S
49
G
138
Posts: 7,962
Reputation: 91,890

Post » Tue Jan 19, 2016 2:27 am

I dug around on the nw.js forums. Apparently, some file in the "manifest.json" ? or "package.json" ? (I'm not sure where these live in the filesystem, if you do, please tell us), can become corrupted, and can "blacklist" the name of your app.

Changing the "Name ______ " of my project in "Project Properties" instantly solved the problem.
Could you try and let us know?
B
25
S
11
G
4
Posts: 191
Reputation: 4,402

Post » Tue Jan 19, 2016 10:46 am

@christina

Same problem here. The 32 Bit Version works once, then I have to rename it, then it works one again. The 64 Bit Version doesn't work it all.
It seems that the window of the 32 Bit Version ist out of the screen, because I see ne NWjs task in the Task-Manger.
B
23
S
3
G
1
Posts: 412
Reputation: 2,062

Post » Tue Jan 19, 2016 12:51 pm

@christina, thanks for the info, I'll be trying this later today after work, thanks for the info!
B
39
S
10
G
14
Posts: 488
Reputation: 10,270

Post » Tue Jan 19, 2016 1:49 pm

Found out that the 64 Bit version is looking for nw.dll.pdb and didn't found it and then crashes.
The 32 Bit version reading data from Users\<username>\AppData\Local\<name of program>
If I delete the directory with the name of the program it works again once without renaming. I seems that the data are corrupt.
B
23
S
3
G
1
Posts: 412
Reputation: 2,062

Post » Tue Jan 19, 2016 4:45 pm

I already have reviewers complaining about the nw.exe not closing, if this isn't fixed it will be an epidemic when my game launches on the 28th :(
B
11
S
3
Posts: 135
Reputation: 1,309

PreviousNext

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests