NW.js problems

Discussion and feedback on Construct 2

Post » Tue Dec 22, 2015 4:34 pm

Hi,
Well, to make it short, I've been using C2 for a while now and I love it, but one thing that seems to be recurrent is the often poor performances of NW for desktop games.

The last two months I've been having several issues with performance or like presently , the debugger not working.
Would there be any other solution instead of relying on NW which seems to be simply unreliable.

Thanks!
B
39
S
10
G
14
Posts: 488
Reputation: 10,270

Post » Tue Dec 22, 2015 4:38 pm

Could you specify what kind of problems? Im currently in the process of making a game with the intention of publishing as NWjs once final.

I would be interested to know what kind of trouble you are getting if possible.
Brick by brick, stone by stone.
B
50
S
22
G
13
Posts: 273
Reputation: 10,413

Post » Tue Dec 22, 2015 4:48 pm

maybe you using bugged plugin or behavior ?
B
103
S
25
G
40
Posts: 1,876
Reputation: 31,885

Post » Tue Dec 22, 2015 5:03 pm

Actually just using platform, AJAX, and FSM. I have at times drops of frame rate. They happen fast but still happen.
Also, right now, its impossible for me to run the debugger. Trued with a new project and had the same issue. I think NW has been giving a lot of issues for the past year or so and its often slow down the process of creating a game.
B
39
S
10
G
14
Posts: 488
Reputation: 10,270

Post » Tue Dec 22, 2015 5:43 pm

What version of C2 and NW.js are you using?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
126
S
29
G
73
Posts: 5,087
Reputation: 51,994

Post » Tue Dec 22, 2015 10:11 pm

@zenox98. the latest versions. r219 and NW.js 0.13.7 alpha
B
39
S
10
G
14
Posts: 488
Reputation: 10,270

Post » Wed Dec 30, 2015 6:10 pm

Is there any news on this? So far I still problems with the debugger in NW.js. Is there any other way we do not depend on NW for desktop games?
So far, I've been slowly doing a transition to Game Maker because of issues like this.
B
39
S
10
G
14
Posts: 488
Reputation: 10,270

Post » Wed Dec 30, 2015 8:12 pm

NW.js is based on the same Chromium browser engine Chrome uses, so in theory should work identically. Does the Chrome browser have the same problems?

If a feature isn't working for you, like the debugger, please file a bug report following all the guidelines so it can be investigated.
Scirra Founder
B
378
S
220
G
84
Posts: 23,868
Reputation: 188,109

Post » Wed Dec 30, 2015 8:16 pm

@Ashley, thanks for your time.
Some users already filed a completed report with the same issues I'm having with the debugger. Strangely, this does not happen if I switch to Chrome.
But in Chrome, the debugger slows down until unplayable in just a few seconds of use.
B
39
S
10
G
14
Posts: 488
Reputation: 10,270


Return to Construct 2 General

Who is online

Users browsing this forum: ErekT, sinistar99 and 6 guests