NW.js windows export not working on certain peoples PC's

Discussion and feedback on Construct 2

Post » Fri Oct 30, 2015 12:53 pm

My setups have R9 280X and 290X as well and I've not had an issue with NW.js exports running.

I use NW10.5 for Steam.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,616

Post » Fri Oct 30, 2015 1:09 pm

ATI R9 3xx series cards had a problem with directx9 some time ago, maybe the last driver broke something...
some ATI had issues with nw.js but on linux/ubuntu
Image Image
B
25
S
14
G
139
Posts: 876
Reputation: 72,510

Post » Fri Oct 30, 2015 1:24 pm

Use the NW.js action "show dev tools" and make it available through some hidden keyboard shortcut or something. This will bring up the browser error console (just like Chrome's) where it will log any errors if they happen in Javascript, and may help shed some light on it.

Also it could be a graphics driver issue, so updating drivers may help. Note Windows NW.js exports by default ignore the GPU blacklist (the --ignore-gpu-blacklist option in package.json), which means even if the drivers are known to be buggy it will still use GPU acceleration instead of falling back to a software renderer. Removing the option will allow the game to fall back to software rendering on known buggy drivers/hardware, which means it will be slow, but work, which is better than fast and doesn't work at all.
Scirra Founder
B
399
S
236
G
89
Posts: 24,539
Reputation: 195,422

Post » Fri Oct 30, 2015 1:39 pm

Thanks for the replies. I'll give them a go and see what happens when they get into contact with me.
B
12
S
4
G
1
Posts: 137
Reputation: 1,519

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 9 guests