Object AVI

For questions about using Classic.

Post » Sun Jul 26, 2009 7:57 am

Hello.

When playing video (.avi) on full screen using AVI object - video blinks and control panel appears at the bottom of the screen (with buttons Play, Pause and Time slider).

Here is a screenshot:


But when video is playing in windowed mode - everything is fine.

Does anybody know how to remove blinking and control panel in the full-screen view?

And another question - what codec for .avi is better to use, that it is reproduced in the new(clear) operation system without specially installed codecs?

Thanks.
B
3
S
2
G
3
Posts: 146
Reputation: 1,567

Post » Sun Jul 26, 2009 9:51 pm

honestly, I never use this plugin. :mrgreen:
B
25
S
3
G
6
Posts: 1,197
Reputation: 5,620

Post » Sun Jul 26, 2009 10:18 pm

I'd pretty much trust Xvid (MPEG4) to be installed :P
but out-of-the-box windows comes with pretty crappy codecs.. among them WMV (not 9)
You could launch the installer for Xvid from a game installer, too.
B
3
S
2
G
4
Posts: 1,445
Reputation: 4,665

Post » Mon Jul 27, 2009 9:55 pm

And what developers of the program can say about this?

Here is an example: [url:awvqy6o2]http://www.fileqube.com/shared/OqXlc1502806[/url:awvqy6o2] 16kb
Here is a Video File: [url:awvqy6o2]http://www.fileqube.com/shared/oCVPv1502805[/url:awvqy6o2] 153kb
B
3
S
2
G
3
Posts: 146
Reputation: 1,567

Post » Mon Jul 27, 2009 9:59 pm

It just uses standard Windows functions, nothing special.
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Tue Jul 28, 2009 3:34 pm

[quote="Rich":2d20vz9e]It just uses standard Windows functions, nothing special.[/quote:2d20vz9e]

Richy, I understand, thanks.

But why when video is playing on full screen using standard Windows Media Player everything is fine and image is displayed correctly (without any blinkings and control panel)? And when video is playing on full screen using Object AVI - video blinks and appears control panel? (you can see that at the screenshot or look at the cap file earlier in this topic)

How to remove video blinking and control panel? Is this problem of Windows and I should reinstall it? Or is it a bug of the program? (once again remind that when video is playing in windowed mode - everything is fine).

P.S. Solution of this problem is very important for me, because I would like to use short videos between the levels in my game. :|
B
3
S
2
G
3
Posts: 146
Reputation: 1,567

Post » Tue Jul 28, 2009 4:54 pm

Maybe the DirectX display inteferes with it. I had to tweak the other window controls (buttons, edits etc) to get them to show right even in windowed mode.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574

Post » Tue Jul 28, 2009 5:50 pm

[quote="Ashley":38krvslo]Maybe the DirectX display inteferes with it. I had to tweak the other window controls (buttons, edits etc) to get them to show right even in windowed mode.[/quote:38krvslo]

Ok.. Could you explain in details how you tweak?
B
3
S
2
G
3
Posts: 146
Reputation: 1,567

Post » Thu Jul 30, 2009 9:38 pm

I'd like to know how to get a video running properly in fullscreen , and how to make the video fullscreen - because I made a fancy intro to my next game ( an unnofficial sequel to an amazingly awesome flash game )
B
3
G
3
Posts: 83
Reputation: 1,041

Post » Thu Jul 30, 2009 10:12 pm

[quote="Instant":1oe6xclq]I'd like to know how to get a video running properly in fullscreen , and how to make the video fullscreen - because I made a fancy intro to my next game ( an unnofficial sequel to an amazingly awesome flash game )[/quote:1oe6xclq]

I'd like to know too... :|
B
3
S
2
G
3
Posts: 146
Reputation: 1,567

Next

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 3 guests