Object blinking even has been set on a specific fr

Discussion and feedback on Construct 2

Post » Mon Apr 01, 2013 11:09 am

Hi,

I am new here, I am using construct 2 to prototype my games. At the moment I am developing a sort of 2D shooting game. The problem I am finding is the following:

When an enemy is shot, the animation "shot" is played.

When "shot" animation is finished, I set the animation on the last frame so the enemy stays lying on the ground.

The problem is every a few seconds I can see how the enemy blinks standing up (it happen for 0.1-0.2 seconds). I have been tracking the issue but I cannot find why is happening.

The enemies has pathfinding behaviour and they have set a few animations when they walk etc, but once they have been shot pathfinding behaviour is disabled. So this is not interfering with the animation.

I have been using "set frame on" before on another objects and it didn't happen this.

Does this happen to somebody else? I would like to clarify before posting it like a bug.

Thanks.
B
9
S
2
G
1
Posts: 4
Reputation: 1,334

Post » Mon Apr 01, 2013 11:18 am

Problem fixed:

I had:

enemy - state: shot - set animation to dying

enemy - on animation finished dying - set frame 5

So every tick the first line was being evaluated. I changed to:

enemy - state: shot - set animation to dying

enemy - on animation finished dying - set frame 5
                                    - set state to "none"

And problem solved.

B
9
S
2
G
1
Posts: 4
Reputation: 1,334


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 5 guests