object falls speed slower on animation

Bugs will be moved here once resolved.

Post » Fri Mar 23, 2012 10:48 am

Hi,

Im not sure if this is a bug or im doing something wrong or maybe i did not read something i should have read :)

Specs: Latest build(64 or 32bit) on Win7 and latest chrome browser version.


If i have 2 objects with physics and object1 has Animation and object2 has no animation following happens:

object with animation will slow down during fall and fall at a low speed.
Object with no animation will fall normaly.

Here is a capx for the issue
http://dl.dropbox.com/u/14594485/teste.capx


Im very sorry if this is something already reported or if im missing something here..

B
28
S
2
Posts: 69
Reputation: 1,491

Post » Fri Mar 23, 2012 4:06 pm

Looks like a bug - hopefully will be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Fri Mar 23, 2012 11:19 pm

Should be fixed in r83 but I wouldn't recommend animating Physics objects: when the animation frame changes, it's like removing the object and teleporting in a new object, which can cause glitches. Instead you should have a unanimated invisible physics object which you place animated objects on top.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Fri Mar 23, 2012 11:46 pm

Thanks for the tip, will change it then :)
B
28
S
2
Posts: 69
Reputation: 1,491


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests