Objects Vanishing

For questions about using Classic.

Post » Mon Nov 15, 2010 10:46 pm

Hello, I'm quite new to Construct, but not to various game scripting programs such as Games Factory and Game Maker.

I am having a bit of difficulty with a layout restarting after the player dies. I am using the
System: Go to Layout LayoutName with Transition "none" lasting 0 MS method to do this.

This appears at first glance to work perfectly, but not all of the objects are reset. With the coin/record objects, some are definitely missing, and it is not the same ones each time the layout
is restarted.

Any ideas how to solve this?

[url:2rxpqljm]http://dl.dropbox.com/u/15091348/nosound.cap[/url:2rxpqljm]
B
2
G
2
Posts: 15
Reputation: 680

Post » Tue Nov 16, 2010 11:35 pm

I have changed the resolution in the .cap so it is more obvious what is happening.

Collect a few coins and fall in to the holes a couple of times, and you will begin to see the issue.

Is there anyway around this problem?
B
2
G
2
Posts: 15
Reputation: 680

Post » Tue Nov 16, 2010 11:44 pm

I've also put a number up showing the number of instances of the record object.
B
2
G
2
Posts: 15
Reputation: 680

Post » Wed Nov 17, 2010 12:08 pm

Uncheck 'global' for the spritefont objects and the objects won't disappear.
B
79
S
24
G
54
Posts: 4,740
Reputation: 40,743

Post » Wed Nov 17, 2010 6:34 pm

Thanks R0J0hound, that's cleared all the problems up. :D

Why did the state of the global variable change the number of records though?
B
2
G
2
Posts: 15
Reputation: 680

Post » Wed Nov 17, 2010 8:27 pm

[quote:3mypuo6u]Why did the state of the global variable change the number of records though?[/quote:3mypuo6u]
It seems to be a bug with the SpriteFont object since it only happens when they are global.
B
79
S
24
G
54
Posts: 4,740
Reputation: 40,743


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 3 guests