"On Any Touch End" not working on Samsung GS3 & No

Bugs will be moved here once resolved.

Post » Wed Jul 24, 2013 7:56 am

Link to .capx file (required!):
http://cdn.mobileembrace.com/uploads/mobileembrace.com/test/SwipeTest.capx

Steps to reproduce:
Hi Guys (long time reader, first time poster),

I appear to have discovered a problem with "On Any Touch End" on the stock Android browser on the Samsung Galaxy S3 and original Samsung Galaxy Note.

Basically I want to build a game for phones with Temple Run style controls, i.e. you swipe the screen left or right to move.

I after reading the forums, I put together a simple file that records the touch position on any touch start and any touch end and compares the X values to work out if the user has swiped left or right.

This seems to work fine on most of the browsers and devices I've tested it on, but not on the Samsung Galaxy S3 or Note.

I added an additional text box to display the Touch.X values that were recorded, and it appears that something is going wrong with the "On Any Touch End" value as it always reverts to it's original value, 0 in this case.

Interestingly if you touch the screen with 2 or more fingers the end touch of any additional touches seems to register, but as soon as you remove your last finger the end touch goes back to 0.

I've tested this on a range of devices and it works fine on all the desktop browsers I've tried and the following devices:

iPhone 4S
Samsung Galaxy Nexus stock browser
Samsung Galaxy S4 stock browser
HTC Desire

It also works on the Chrome mobile browser on the affected devices (the GS3 and Note), but unfortunately most people use the stock browser and the Galaxy S3 is second only to iPhones in our target audience.

If anyone can suggest any workarounds, I would be very grateful!


Observed result:
"On Any Touch End" not working on Samsung GS3 & Note

Expected result:
"On Any Touch End" to work on Samsung GS3 & Note!


Browsers affected:
Chrome: no
Firefox: no
Internet Explorer: no

Operating system & service pack:
Windows 7 Professional Service Pack 1

Construct 2 version:
Construct 2 Release 139 (64-bit)


Thank you!
B
30
S
7
Posts: 23
Reputation: 1,871

Post » Wed Jul 24, 2013 5:53 pm

Man, the Android stock browser is just garbage. It's a bug in the browser, it simply fires 'On touch end' twice for releasing a single touch. I've fixed it for the next build. The next build might be delayed a couple of weeks due to holidays; in the mean time knowing 'On touch end' is firing twice might help you work around it, since you just need to find a way to ignore the second spurious 'On touch end' event.
Scirra Founder
B
403
S
238
G
89
Posts: 24,654
Reputation: 196,145

Post » Thu Jul 25, 2013 4:09 am

Thanks Ashley!

If I get a work around up and running before then I'll try and post it here.
B
30
S
7
Posts: 23
Reputation: 1,871


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 7 guests