On update ready is not trigered on first load

Discussion and feedback on Construct 2

Post » Fri Mar 15, 2013 9:45 am

Hello fellas,

This problem appears only in chrome and safari, firefox works well. I'm using browser object "Is downloading update" and "On update ready" to force update on the client. It's weird, but the first time the page is being loaded "On update ready" is not trigered. After you refreshed the page and uploaded a new update it works.

And yes, I upload all game files including "offline.appcache"

I think I even saw this behavior on some game on Scirra Arcade. The guy wrote in the description "If you stuck on downloading update, please refresh the page."

Any ideas how to fix it?xoros2013-03-15 09:47:16
B
42
S
11
G
4
Posts: 505
Reputation: 7,267

Post » Fri Mar 15, 2013 1:56 pm

if you are visiting the URL for the first time why should an update work?
B
18
S
5
G
4
Posts: 568
Reputation: 5,079

Post » Fri Mar 15, 2013 2:03 pm

Yes I understand, but the thing is, when the page is visited for the first time the event "Is Downloading Update" ist still trigered, but "On Update Ready" is not trigered.
B
42
S
11
G
4
Posts: 505
Reputation: 7,267

Post » Mon May 06, 2013 4:29 pm

So, it is still an issue: Browser>OnUpdateReady is not triggered, when the page is loaded for the first time (when it wasn't cached before). Loading progress shows 100%, but this event is not triggered. I checked everything possible and my server supports .appcache MIME-type.

If it was cached one time, onUpdateReady works.
B
42
S
11
G
4
Posts: 505
Reputation: 7,267

Post » Mon May 06, 2013 5:16 pm

You can simple download the sample file here and read the tutorial, it may help you.

https://www.scirra.com/tutorials/533/for-beginners-custom-loading-screenTELLES08082013-05-06 17:17:29
ImageImageImageImageImageImage
B
92
S
19
G
12
Posts: 1,192
Reputation: 18,276

Post » Tue May 07, 2013 8:51 am

Ok, thanks man, with the help of your example I have figured out another way how to achieve that. But the issue with "OnUpdateReady" is still there, cause it's not get triggered on the first time loading.
B
42
S
11
G
4
Posts: 505
Reputation: 7,267


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 3 guests