One-shot particles ignore set angle

Bugs will be moved here once resolved.

Post » Fri Feb 17, 2012 6:19 pm

So when you create particles and set the angle in the same event, it doesn't work for one-shot particles. Particles in continuous mode assume the angle correctly.

Here's a demonstrational capx file: Particles example

Click to create particles, one-shot particles will always stay at an angle of 0. While continuous ones change correctly to 180.

PixelRebirth2012-02-17 18:20:48
B
21
S
6
G
10
Posts: 1,024
Reputation: 7,445

Post » Mon Feb 20, 2012 10:13 pm

Thanks, should be fixed in next build.
Scirra Founder
B
367
S
217
G
82
Posts: 23,262
Reputation: 183,679

Post » Sun Oct 04, 2015 1:46 am

this still isnt fixed
B
3
Posts: 4
Reputation: 183

Post » Sat Oct 17, 2015 9:44 pm

shocker1185 wrote:this still isnt fixed


Annoying. spent a few hours wondering where i was going wrong with this.
Any danger of a fix? Pretty please?

In the meantime, I wonder if i can simulate the type of one shot i want by manipulating the continuous spray?
B
5
S
1
G
1
Posts: 5
Reputation: 352

Post » Sat Oct 17, 2015 9:57 pm

@shocker1185, @Halomalo

This is a closed bug report.

If you think there is still a problem, then post a new bug report, ensuring you follow all of the guidelines, and Ashley will investigate.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
124
S
29
G
70
Posts: 4,977
Reputation: 49,691


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest