Optimizing a custom Sonic engine

Get help using Construct 2

Post » Fri Oct 26, 2012 6:50 am

I've been trying to completely re-do my Sonic engine step-by-step, starting with the stuff that works, reworking things to avoid using functions, and generally trying to make everything work, I've already run into issues.

I'm currently using a platform behaviour as a stand-in to test basic multiplayer movement, and while that works as intended, I found that implementing sensors on their own results in some nasty framerate drops. My computer is quite fast, and to see a bare framework of code cause the framerate to drop below 60 is disconcerting to me.

https://dl.dropbox.com/u/919275/SC2WOverhaul.capx (Need standard license, r108.2)

It's hardly complex, it's mainly a bunch of sensors being stuck in certain spots (with an algorithm in place for them to move according to any player rotations). "Collision Old" is the original set of sensor events, while "Collision" is me trying to mess around and try and find an alternative method (which isn't going particularly well).

I'm gonna keep this thread as an on-going series of incremental implementations, trying to figure out what works and what doesn't, and what to do differently.

So, first question: How can I optimize the sensors while keeping their ability to position themselves properly as the player rotates?
Posts: 404
Reputation: 11,275

Return to How do I....?

Who is online

Users browsing this forum: Bilderberg CEO, Burvey, jbr190, Mikhail80, Phobos70, powerwaffle, runningtech and 33 guests