Output Display Weirdness

Get help using Construct 2

Post » Wed Dec 28, 2011 2:08 pm

Hello. First time designer here, confused what setting is causing this output when following the beginner tutorial:

B
2
G
1
Posts: 4
Reputation: 458

Post » Wed Dec 28, 2011 2:40 pm

probably unbounded scrolling set to Yes in the Layout Properties
B
60
S
22
G
14
Posts: 1,479
Reputation: 16,346

Post » Wed Dec 28, 2011 3:10 pm

It's set to No. Any other thoughts?
B
2
G
1
Posts: 4
Reputation: 458

Post » Wed Dec 28, 2011 3:11 pm

You have zoomed in or out in your browser?
B
6
S
1
G
1
Posts: 42
Reputation: 810

Post » Wed Dec 28, 2011 3:12 pm

Then probably your tiled background object(ground) isn't the same size as your layout.
Image Image
B
161
S
48
G
90
Posts: 7,347
Reputation: 66,749

Post » Wed Dec 28, 2011 3:34 pm

I have both the background and the layout set to 960x640.

My browser isn't zoomed.

Another weird thing is the mouse pointer reacts as if the player was in the center of the larger box, so I can have my pointer to the upper right or where I see the player, but since this position is to the lower left of the center of the larger box, he turns to face the lower left.

It also displays my score in the very upper left corner on the white area.

The red circle indicates the position of my mouse at the time of the screenshot:



This is using Firefox, btw.Kuroiryu2011-12-28 15:38:29
B
2
G
1
Posts: 4
Reputation: 458

Post » Wed Dec 28, 2011 3:50 pm

You would save a lot of time by posting the .capx. If you're not sure how, see THIS tutorial.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,841
Reputation: 48,283

Post » Wed Dec 28, 2011 4:06 pm

Unfortunately, I closed and reopened the project and all my work wasn't saved even though I had told it to so I can't post my .capx, however I see the same effect when I play

http://www.scirra.com/arcade/shooter/32/ghost-shooter-demo

This doesn't happen with any of the other games I've tried in the arcade though.
B
2
G
1
Posts: 4
Reputation: 458

Post » Wed Dec 28, 2011 6:28 pm

Sounds like a drivers issue.
I'm using firefox too, and the ghost shooter from arcade displays correctly.

Be sure to update FF (current version 9.0.1) and your graphic card drivers.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791


Return to How do I....?

Who is online

Users browsing this forum: newt, Yahoo [Bot] and 29 guests