Particle ghosting

Bugs will be moved here once resolved.

Post » Mon Apr 02, 2012 3:26 pm

Steps, load capx, shoot a spider. awesome explosion! Then shoot another, odd, I saw the 1st explosion for half a second.
capx: http://game.paleoketo.com/shoot/jshtest.capx
Win 7 64, 1.84 64 b5it, ati 6350 vid card, chrome 18.0.1025.142 m. Would a dxinfo help?
B
5
Posts: 17
Reputation: 460

Post » Mon Apr 02, 2012 3:35 pm

Can't reproduce, works as intended in both FF and Chrome for me.
No ghosting or whatever.

Are your graphic card drivers up to date ?
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Mon Apr 02, 2012 4:34 pm

Just double-checked, yep up-to-date.
B
5
Posts: 17
Reputation: 460

Post » Mon Apr 02, 2012 8:46 pm

Link is a 500 error here.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Mon Apr 02, 2012 9:42 pm

Ahhrrggh! cleared directory, sorry
http://game.paleoketo.com/jshtest.capx



Edit: works fine on my son's old nvidia, also correction, vid card is 6310, not 6350.silverback2012-04-02 22:34:38
B
5
Posts: 17
Reputation: 460

Post » Thu Apr 12, 2012 5:25 pm

Can you reproduce in a new project from scratch? Otherwise it could just be a mistake in your events.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Thu Apr 12, 2012 8:56 pm

Hi,

I have been seeing this problem too, but only on canvas. You can see an example of this if you look at the Space Shooter dev app at http://www.m2ag.net/dev/shooter/ with a canvas browser (ie i guess). Just enter the game and select the dev game on the first menu. Click the glowing bar at the bottom and shoot the (white) ice. Shooting ice one after the other will show the flashes. It shows up really well on ipad, but the current version of my game is afu on the ipad right now.

I tried blaming it on Construct2's canvas renderer, but it turns out I was doing it wrong.

The ice_explosion sprite is a one shot shared between all the ice sizes. To clear the flashing up I destroy the ice explosion object before the one shot particle timeout.

In this case I set the Particle life time Timeout to 2.1, and in my event triggering the explosion I wait 2.0 seconds before the end and destroy the object.


Marc
marcgram2012-04-12 21:12:57
B
330
S
7
G
2
Posts: 27
Reputation: 10,791

Post » Fri Apr 13, 2012 9:38 am

@marcgram, we can't do anything without a .capx of a new project reproducing the issue with the Particles object on it's own, which is what I've been asking for in this thread - any chance you can provide one?Ashley2012-04-13 09:38:29
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests