Particle grow rate stops past a certain size

Bugs will be moved here once resolved.

Post » Mon Apr 28, 2014 6:03 pm

Problem Description
Particles doesn't grow past a certain size, unless I resize the size of the browser.

Attach a Capx
particleproblem.capx


Description of Capx
I have a particle emitter that grows particle from 32px to 1000px as it fades out. No speed no gravity nothing else than grow rate.

Steps to Reproduce Bug
  • Create particle emitter at size 32px
  • Make it grow to 1000px
  • No speed, no gravity.

Observed Result
It stops before expanding to a complete 1000px wide

Expected Result
It should grow out of the screen until it fades out completely.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Windows 7

Construct 2 Version ID
r168
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 7
Reputation: 189

Post » Mon Apr 28, 2014 6:14 pm

Just linked a new file, the other wasn't the right one.
B
3
Posts: 7
Reputation: 189

Post » Mon Apr 28, 2014 8:39 pm

Setting grow rate to 1000 doesn't mean size will up to 1000px. It says "Rate the size changes over time, in pixels per second.". If timeout is 3, i expect it to size particles to 3000px (1000px * 3) not to 1000px. It seams everything works ok here. Nice effect by the way :) . i wish i have your imagination... :)
B
11
S
2
G
1
Posts: 25
Reputation: 1,685

Post » Mon Apr 28, 2014 11:17 pm

Thanks for the reply! Even if I set the timeout to 10 seconds it won't grow to 1000px. It should have the time to grow that big?
B
3
Posts: 7
Reputation: 189

Post » Tue Apr 29, 2014 6:56 am

I have tried that with 10 seconds timeout on circle shaped particle, it worked normally.
B
11
S
2
G
1
Posts: 25
Reputation: 1,685

Post » Tue Apr 29, 2014 7:08 pm

Can you link me your capx file? Does the particle goes out of the screen?
B
3
Posts: 7
Reputation: 189

Post » Tue Apr 29, 2014 8:55 pm

https://www.dropbox.com/s/dvlel2n42zyj2 ... oblem.capx

I have set only the circle shaped ("Particles") particle's timeout to 10.

Yes, it goes out the screen.
B
11
S
2
G
1
Posts: 25
Reputation: 1,685

Post » Tue Apr 29, 2014 9:41 pm

It seems that in a certain resolution, it doesn't scale past a certain size... I tried it on different screens and it's certainly a problem because when I resize the browser it works. Can we scale a particle infinitely? Maybe not.
B
3
Posts: 7
Reputation: 189

Post » Wed Apr 30, 2014 8:27 am

Can you link me the capx which you are talking about (set at certain resolution). May be i can help.
B
11
S
2
G
1
Posts: 25
Reputation: 1,685

Post » Wed Apr 30, 2014 7:04 pm

I think it might be a graphic card issue? Because it works fine on my laptop and not on my PC...

The capx file you have is exactly what I have, the grow rate should infinitely expand a particle until the time you set out as a timeout. Even if I put 1000px as a grow rate and 20 seconds as TimeOut it still stops at a certain size. Not covering the entire screen.

We tried on a bunch of different computers, and it's working for the others, not mine. So Construct people, if you read this I think we might have a real bug here ;)

this is my graphic card : Geforce GTX 780 / PCIe / SSE2 /

OpenGL 4.4.0
B
3
Posts: 7
Reputation: 189

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests