Particle start time

Get help using Construct 2

Post » Sat Apr 06, 2013 4:05 am

I crated a Snow-Like particle.

My problem is that when the program starts it "starts" snowing. But I need to to "be snowy" when I start the game.

Any solution?
B
2
Posts: 3
Reputation: 406

Post » Sat Apr 06, 2013 4:08 am

Well...I guess you could find a work around, like having a fade-in, or perhaps in your game later the weather changes and it starts snowing.Sushin2013-04-06 04:08:53
B
10
S
3
G
3
Posts: 234
Reputation: 3,467

Post » Sat Apr 06, 2013 10:40 am

There's no way to pre-play the particle effects, so Sushin is right - you'll have to find a workaround.

Is it always snowing in your game? Would you say that it's snow-themed? If so, I'd suggest that you make your snow particle system global (i.e.: it's not destroyed between layouts) and place it in your initial title screen (just mock one up for the sake of testing if you don't already have).

Actually, thinking about it now I'd say you could even generate the particle system while the game is loading. If you'd rather not have it look like it's there, then just set it to invisible. Read about custom loading screens here.GeometriX2013-04-06 10:46:28
B
56
S
15
G
10
Posts: 910
Reputation: 11,972

Post » Sat Apr 06, 2013 11:21 am

You could have an 'one off' particle object that runs at start of the layout. It would create a huge burst of snow at once and sort of work as a preset before the game actually starts.
B
24
S
8
G
7
Posts: 756
Reputation: 7,202

Post » Sat Apr 06, 2013 12:37 pm

You could set an event that drastically increases the flow rate and particle speed for the first few ticks. No idea if it will work.
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400


Return to How do I....?

Who is online

Users browsing this forum: Lof, YoHoho and 22 guests