Pathfinding Behavior

Get help using Construct 2

Post » Thu Jan 31, 2013 12:05 am

Hi all!

I have a problem with the pathfinding behavior (you can see it in motion here: http://www.scirra.com/labs/pathfinding/)
I made a simple test (the cap: http://dl.free.fr/jAz0EeZsY) but as you can imagine, it does not really do the same ...
My sprite does not even turn to the first corridor.
A little help to a poor lost user will be highly appreciated.

Thank you in advance (and even forgiveness for my "google" english).
B
19
S
4
G
2
Posts: 13
Reputation: 2,267

Post » Thu Jan 31, 2013 12:10 am

Mouse: On Left button Clicked -> Sprite2: Find path to (Mouse.X, Mouse.Y)
Sprite2: On Pathfinding path found - > Sprite2: Move along path
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Thu Jan 31, 2013 12:20 am

Oh! Thank you very much, it was so simple ... So I feel stupid.
So I'll try to get away with another question.
Why is my sprite it more time to calculate its path compared to the example scirra (though more complex)?
B
19
S
4
G
2
Posts: 13
Reputation: 2,267

Post » Thu Jan 31, 2013 12:30 am

Play around with Cell size and Cell border oprions in Pathfinding behavior

If you press on Cell size, tooltip on the bottom of Properties window will tell you "... Smaller sizes will use more CPU"

Try larger values.
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Thu Jan 31, 2013 12:41 am

Ok I'll try it all! Thank you very much for your help and your speed!
B
19
S
4
G
2
Posts: 13
Reputation: 2,267


Return to How do I....?

Who is online

Users browsing this forum: Yahoo [Bot] and 12 guests