Pathfinding doesn't arrive at exact location?

Get help using Construct 2

Post » Fri Aug 05, 2016 9:14 pm

I also have noticed this with path finding movement and decided to use other behaviors (may not be possible in all situations)

I had a player move towards enemy on path finding movement and had an event for on collision to attack (since enemy was still moving I didn't want to wait for arrival and have them walk past each other). Sometimes it would "arrive" at the enemies origin but wouldn't be close enough to cause collision.

Also had zombies that were supposed to take a few steps at a time so it was path finding a small distance. Randomly it wouldn't move at all when it was supposed to. I could never trouble shoot it. I guess now I know it was "close enough" so didn't move at all.

I know this post doesn't help you but I am interested in any resolution as right now path finding movement is my last choice, unless there is an actual maze.
ImageImageImage
B
39
S
22
G
11
Posts: 492
Reputation: 9,925

Post » Sat Aug 06, 2016 1:57 am

I guess it can't hurt filing as a bug. If it is intended behaviour then Ashley will know and just close the report. If not then he will fix it at some point ;)

~Sol
Tired of crappy file hosts that are crappy? Get DROPBOX - https://db.tt/uwjysXJF
Moderator
B
83
S
34
G
40
Posts: 3,032
Reputation: 30,474

Post » Sat Aug 06, 2016 4:25 am

badmoodtaylor wrote:I also have noticed this with path finding movement and decided to use other behaviors (may not be possible in all situations)

I had a player move towards enemy on path finding movement and had an event for on collision to attack (since enemy was still moving I didn't want to wait for arrival and have them walk past each other). Sometimes it would "arrive" at the enemies origin but wouldn't be close enough to cause collision.

Also had zombies that were supposed to take a few steps at a time so it was path finding a small distance. Randomly it wouldn't move at all when it was supposed to. I could never trouble shoot it. I guess now I know it was "close enough" so didn't move at all.

I know this post doesn't help you but I am interested in any resolution as right now path finding movement is my last choice, unless there is an actual maze.


Well I have been using an "On Arrived" + "Move To" to get the moving object to reach the center of the target. It doesn't feel natural if you really concentrate (doubt players will notice if they are engaged). It is good for now though as I haven't gone for polish yet.

SoldjahBoy wrote:I guess it can't hurt filing as a bug. If it is intended behaviour then Ashley will know and just close the report. If not then he will fix it at some point ;)

~Sol


Done, I filed a bug report and hopefully it will be fixed with one of those updates :)
B
19
S
7
Posts: 161
Reputation: 1,751

Previous

Return to How do I....?

Who is online

Users browsing this forum: Lancifer, MPPlantOfficial, Sup with that?, ultrafop, Yahoo [Bot] and 62 guests