Performance Drop Down

Get help using Construct 2

Post » Wed Aug 08, 2012 6:10 pm

Hi folks,

i created a game that is almost done. Android Performance is bad but i prefer to export and play it on Metro.
Now if a Ball fall out of layout the ball would be destroy.
When i click on a button than a new Ball will be spawned. And every time a ball destroy and a new one was created the performance drops down. After the 4th creation of the ball the game is unplayable by around 5fps. Dont know why.

My Notebook has a Core i7 i3610, 8GB RAM, Geforce GTX670M and a SSD.


How can i improve my performance and what could be the reson for the performance drops.

kind regards

intelmaster
B
3
Posts: 17
Reputation: 609

Post » Thu Aug 09, 2012 1:45 pm

No solution for the problem ?
B
3
Posts: 17
Reputation: 609

Post » Thu Aug 09, 2012 2:11 pm

Have you read performance tips?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Thu Aug 09, 2012 2:50 pm

Yes of course and i have things optimized that i can optimize :D . So @ the beginning the Performance is very good but after the 3rd or 4th attempt the Performance DropsDown. Can i PM you Ashley with a capx file. I recently bought the Personal Edition cause if the Bug is fixed i can release my app into the Windows 8 Store. The App excellence Lab has already called me for a talk because they are very interested in my game :-)
B
3
Posts: 17
Reputation: 609

Post » Thu Aug 09, 2012 5:43 pm

if the performance gets progressively worse the longer you play that sounds like somewhere your creating objects and never getting rid of em
B
13
S
5
G
2
Posts: 306
Reputation: 3,262

Post » Fri Aug 10, 2012 11:31 pm

Hey,

now i know that the Debugger of Windows 8 has cause the DropDown. If i run the App native without the Debugger it runs flawlessy fine with no drop downs after some attempts.

Could be a bug of Visual Studio or an Export Bug from Construct 2.
B
3
Posts: 17
Reputation: 609


Return to How do I....?

Who is online

Users browsing this forum: blackhornet, jeffige, TheHat, Yahoo [Bot] and 0 guests