Performance drop

Discussion and feedback on Construct 2

Post » Thu Oct 03, 2013 11:00 am

Which browsers have you tested?

V-syncing can make framerate jumps bigger than they actually are - at 60.1 FPS, it will successfully V-sync at 60 FPS, but at 59.9 FPS, it will keep missing a V-sync interval and can often jump right down to 30 FPS. The actual frame processing time only changed by 0.2 FPS though. So it could be a very small change. It's important to at least test Chrome, Firefox and IE though, to verify whether it's just one browser or consistent.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,226

Post » Thu Oct 03, 2013 11:26 am

@Ashley Just Chrome, but it's back to normal after I did a system restore to before a critical windows update, and a direct x update.
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 961
Reputation: 10,717

Post » Thu Oct 03, 2013 11:27 am

Performance dropped with Chrome update... 60 FPS to 30 FPS...
B
55
S
14
G
10
Posts: 43
Reputation: 9,403

Post » Thu Oct 03, 2013 11:28 am

I test my game on every C2 and Chrome update.
B
55
S
14
G
10
Posts: 43
Reputation: 9,403

Post » Thu Oct 03, 2013 12:14 pm

@Ulisses Check your system restore points. What was recently installed?
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 961
Reputation: 10,717

Post » Thu Oct 03, 2013 12:48 pm

So Firefox and IE are fine? So it must be a Chrome issue, not a C2 issue. I'm reading there may be some issues with the latest Chrome 30 update: http://www.html5gamedevs.com/topic/1589-chrome-30-performance-drop/ - hopefully they'll have it fixed soon...
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,226

Post » Thu Oct 03, 2013 12:51 pm

Actually, I can confirm: Chrome 30 drops most games to 30 FPS instead of 60 FPS. The workaround in that thread is to disable GPU compositing. Firefox and IE are fine still at 60 FPS, so it's definitely a Chrome issue. Perhaps your system restore put you back on Chrome 29.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,226

Post » Fri Oct 04, 2013 1:31 am

Thanks! It's a Chrome issue. I updated it now and my game works!
B
55
S
14
G
10
Posts: 43
Reputation: 9,403

Post » Fri Oct 04, 2013 1:42 am

uh-oh. Hope this doesn't roll over to Node-webkit.
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Fri Oct 04, 2013 12:52 pm

Many thanks for the head's-up on this issue!
B
18
S
3
G
2
Posts: 28
Reputation: 2,684

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 4 guests