Performance Issues

Discussion and feedback on Construct 2

Post » Sun Apr 17, 2016 1:17 am

Alright, so I have 2 quick questions to ask.

#1. Hi, so I'm following the tutorials in the Level 0 ebook and right now I'm making the 'Jumble Art' game. I've noticed that after I've added music and some animations, the game takes up nearly 1 gig of memory on the layout screen. Is this normal, or is it a bug in Construct 2? I know that when compared to today, my computer looks like it came from the stone age, but 1 gigabyte for this game is kinda ridiculous.

#2. When you debug the layout, is the game supposed to run slow? I was running the first game in the Level 0 book-Bubble Pop Madness- and when debugging, the game chugged, like 5-9 FPS. (Using Google Chrome, btw.)
Running it normally doesn't cause any issues.

Any help is appreciated.

https://www.dropbox.com/s/5fz6rep6qnmf57y/Bubble%20Pop%20Madness.capx?dl=0
https://www.dropbox.com/s/n9svawobjbwb7be/Jumble%20Art.capx?dl=0

Specs:
Computer: Compaq Presario CQ57
CPU: AMD C-50 Processor 1.00 ghz
GPU: AMD Radeon 6250 Graphics
RAM: 2gb DDR3
B
10
S
3
G
1
Posts: 13
Reputation: 1,271

Post » Sun Apr 17, 2016 4:03 am

Hey ! just tested the capx files and performance is great. The memory usage is around 19mb so i'm not sure as to why you are getting 1gb . As for the debug tool, it usually requires more resources so most times it runs way slower than how it actually runs but even when i run the debug tool i get 50 fps
Image
B
60
S
32
G
5
Posts: 118
Reputation: 8,325

Post » Sun Apr 17, 2016 4:15 am

Maybe I need to buy a new laptop. In task manager, C2 was hogging up nearly 800mb of memory (Jumble Art). Only C2 was open with no background tasks.
B
10
S
3
G
1
Posts: 13
Reputation: 1,271

Post » Sun Apr 17, 2016 5:37 am

Ser ch4Pi wrote:#2. When you debug the layout, is the game supposed to run slow? I was running the first game in the Level 0 book-Bubble Pop Madness- and when debugging, the game chugged, like 5-9 FPS. (Using Google Chrome, btw.)
Running it normally doesn't cause any issues.

I'm not sure if it is just on my end but I usually separate the debug ribbon from the game canvas while debugging and everything runs fine then.
There is a small button to do that, you should try it out yourself, it might help you out. (Note: you have to manually do that every time when you want to debug.)
ImageImageImage
B
63
S
23
G
78
Posts: 661
Reputation: 44,935

Post » Sun Apr 17, 2016 5:49 am

Hi,

my laptop is new and fast, but has some issues with html5 speed (and so also C2 games)- so it's great for testing (because here you see ALL problems with your game)

Jumble Art:
C2 takes 1500MB RAM - so something is off. But it doesn't matter if you have enough RAM

Bubble Game - 30fps up to 50% CPU in Chrome (debug mode)
the game isn't well optimized
But this depends totally on which computer and browser you are testing
Like with Edge I get 50fps.
The problem here is that in debug mode a lot of stuff is watched.
So if you click the "watch" tab and only monitor some of the parameters (the eye symbol) I get 58fps and 3% CPU


Some infos about my hardware:
W10 i3-5010U, 4GB Laptop - has some major issues with HTML - but otherwise a great and fast Laptop
W10 i5-6500, 16GB, GTX960, SSD Workstation - has also some issues with HTML - otherwise perfect
W10 i5-5200U, 8GB, SSD Laptop - no issues at all - runs even HTML5 like a charm

So maybe you need a new laptop
if W10 - switch to Edge in debug or choose which parameter you like to see

  • System > On start of layout | system > load game from slot "brain"
  • System > On load failed | system > scroll to obj_Forum
B
17
S
8
G
5
Posts: 340
Reputation: 4,707

Post » Sun Apr 17, 2016 6:24 am

fm4fanAT wrote:Bubble Game - 30fps up to 50% CPU in Chrome (debug mode)
the game isn't well optimized
But this depends totally on which computer and browser you are testing
Like with Edge I get 50fps.


I'm going to test other browsers and see how C2 handles. I'm definitely going to upgrade the ram asap. Btw this is probably one of the most helpful and active communities I've been apart of. Thanks guys! :D
B
10
S
3
G
1
Posts: 13
Reputation: 1,271

Post » Sun Apr 17, 2016 6:54 am

Bubble Game - 60FPS, 4.3mb image memory, 15-20% CPU
Jumble Art - 60FPS, 9.4mb image memory, 14-15% CPU

Both tested in Firefox with debug mode on a laptop with 8GB DDR3 RAM and an Intel i3-3110m CPU.
So your games run fine, but the C2 editor does take up 1.3gb memory when opened Jumble Art (and around 200mb when opened Bubble Game). It might be a bug that causes this, so I suggest you file a bug report and see what the Scirra Team has to say about this. bugs_f151
B
135
S
33
G
17
Posts: 1,557
Reputation: 20,717

Post » Sun Apr 17, 2016 7:13 am

glerikud wrote:It might be a bug that causes this, so I suggest you file a bug report and see what the Scirra Team has to say about this. bugs_f151


Will do, thanks!
B
10
S
3
G
1
Posts: 13
Reputation: 1,271


Return to Construct 2 General

Who is online

Users browsing this forum: mihirolover and 14 guests