Performance

Get help using Construct 2

Post » Sat May 02, 2015 1:40 pm

Hi
I have been having a problem recently where my games become buggy when I have 3-4 plus levels/layouts( for instance the controls won't work when they where working fine before or objects won't work even though they worked before). I am using the free version so is that why this is happening ? ( by the way all my assets are imported and my games are quite complex but I didn't exceed any of the limits).

Please reply if this is happening to you or it is just the free version.

Thanks
Banned User
B
4
S
1
Posts: 6
Reputation: 366

Post » Sat May 02, 2015 1:52 pm

Other than restrictions, there is no difference between a free version and a licensed version. It is more than likely a problem in your events, but without a .capx, no-one will be able to help effectively.

If you could re-create in a simple .capx and upload then it will be much easier for the forum to help you.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
131
S
29
G
81
Posts: 5,328
Reputation: 56,630

Post » Sat May 02, 2015 7:10 pm

p.s. this is posted in wrong section (I'm seeing your question posted on completed addons section)

Anyway, in addition to what Xenox said, in case you're hesitant about sharing your capx, you can use the debugger to find out bottlenecks in your code. Often too many draw calls or running events every tick can really kill the performance. Analyse the code you have written and think how a machine would operate, and how things could be further optimized. Without seeing the capx, my assumption is that probably it could be some performance-related problem but there can be many other roots too. it may sound basic, but have you checked what event sheet those layouts are linking to? perhaps you should include some other layouts holding the controls etc.
B
14
S
3
G
1
Posts: 77
Reputation: 1,035


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 11 guests