PhoneGap Build Error

Ideas and discussion about publishing and distributing your games

Post » Thu Sep 07, 2017 5:00 pm

Does any know how to fix this error with PhoneGap:

Error - One of your plugins requires a parameter: BILLING_KEY

I have searched the forum and have not found an answer to this. File size is only 8MB so this is not the problem, any help would be much appreciated.
B
5
S
1
G
1
Posts: 4
Reputation: 835

Post » Sat Sep 09, 2017 11:57 pm

Problem solved, build was successful with Construct 3 build service. App is uploaded to the Google Play for testing.
B
5
S
1
G
1
Posts: 4
Reputation: 835

Post » Sun Sep 10, 2017 1:12 pm

Build was successful, but still need to add Billing Permissions to apk before in app purchases can be used. I found this link hope it helps others with this issue.

https://android-developers.googleblog.com/2017/06/money-made-easily-with-new-google-play.html

:shock: :?
B
5
S
1
G
1
Posts: 4
Reputation: 835

Post » Mon Sep 11, 2017 4:10 pm

Nope, didn't have to follow that link. Just updated IAP from Construct 2 to Mobile IAP in Construct 3 and Google Play store accepted the apk. In app purchases was unlocked afterwards in Google Play Console.
B
5
S
1
G
1
Posts: 4
Reputation: 835


Return to Distribution and Publishing

Who is online

Users browsing this forum: No registered users and 0 guests