Phonegap Builds failing after Release 227

Discussion and feedback on Construct 2

Post » Fri May 20, 2016 5:19 pm

Hi, I'm trying to export my app for android, using cordova export, into phonegap.

All this worked perfectly until I updated to 227. I did what the patch notes suggest: Forcing 6.0 build machine on phonegap. It still doesn't work.

Exporting the game for android 5.0+ does work, but that's no good for me. I need 4.1+

Please some help.
B
7
S
1
Posts: 13
Reputation: 754

Post » Fri May 20, 2016 5:28 pm

FAILURE: Build failed with an exception.

* Where:
Script '/project/cordova-plugin-crosswalk-webview/daishisushi-xwalk.gradle' line: 73

* What went wrong:
A problem occurred evaluating script.
> Could not find property 'xwalkMultipleApk' on root project 'project'.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED
B
7
S
1
Posts: 13
Reputation: 754

Post » Fri May 20, 2016 7:58 pm

I finally succeded, had to add this to the config.xml:
<preference name="android-versionCode" value="1" />
In addition to:
<preference name="phonegap-version" value="cli-6.0.0" />
B
7
S
1
Posts: 13
Reputation: 754


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 14 guests