Physics connection bug

Bugs will be moved here once resolved.

Post » Sun Apr 14, 2013 10:20 pm

Link to .capx file (required!):
http://www.upload.ee/files/3233670/dwarf2.capx.html

Steps to reproduce:
1. Open Layout 5
2. Start preview
3. Drive a little
4. Save game
5. Load game

Observed result:
When reloading the save or restarting the layout the game occasionally crashes. When I referesh the page and load my saved spot, everything works fine, but after I reload the second time it crashes. Could you please chech and tell me if this is because of bugs in C2 or am I doing something wrong with my physics behaviors.

Expected result:
Load and refresh without crashing.

Browsers affected:
Chrome: yes
Firefox: yes
Internet Explorer: yes

Operating system & service pack:
windows8 64 bit
Construct 2 version:
    r125
B
14
S
5
G
4
Posts: 107
Reputation: 4,758

Post » Mon Apr 15, 2013 2:54 pm

It works for me. Can you provide more detailed steps about exactly what you are doing?

Please also remember to include the exact text of any error messages that appear. In this case you refer to "crashes", which should include some information about the problem in error messages, but since I can't reproduce the problem I don't know what that information is.

Note you use save and load inefficiently. 'A is down' is true every tick, so you're saving 60 times a second while the A key is down, and similarly loading 60 times a second while the D key is down. You should replace them with 'On key pressed' triggers.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Mon Apr 15, 2013 7:45 pm

OK, I got my saving a little better, but it still crashes, when I
1.save
2.load save
3.restart
4.load again

Try combining them together, see if you can reproduce it.
Best regards.

PS here is a picture about the error http://www.upload.ee/image/3236100/Untitled.png

In chrome it says, that "col undefined" but in IE "col 5" if this is of any help.trollface2013-04-15 19:48:22
B
14
S
5
G
4
Posts: 107
Reputation: 4,758

Post » Wed Apr 17, 2013 4:46 pm

Thanks, this should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest