Pixel display problem

Discussion and feedback on Construct 2

Post » Sun Jan 22, 2017 11:34 am

It is the horizontal lines that are disappearing. I had that happen in a game and if I remember correctly I fixed it by having the editor image at original size and then setting the image to the size I want in the settings and you may have to play with those settings to maintain the proper ratio.

Also recheck your image points have not slipped out of line and if there is any white or light gray borders around images crop them off as that throws off the alignment for some reason and run it in letterbox integer scale.

Oh and check your layout and view scale. They need to be in even increments of 16 pixels like 640x640 otherwise the raster will miss pixels and that would explain why the horizontal lines are missing.

Best of luck because I remember fighting images that did that!
Banned User
B
23
S
6
G
58
Posts: 1,229
Reputation: 34,540

Post » Sun Jan 22, 2017 2:52 pm

lamar wrote:It is the horizontal lines that are disappearing. I had that happen in a game and if I remember correctly I fixed it by having the editor image at original size and then setting the image to the size I want in the settings and you may have to play with those settings to maintain the proper ratio.


This sounds promising, could you elaborate? I'm not completely following you. The settings for the sprite object? Everything is currently in the layout editor at 1:1 scale, with the entire layout enlarged by 1.8 scale in events. What do I change, without rebuilding my entire game?

lamar wrote:Also recheck your image points have not slipped out of line and if there is any white or light gray borders around images crop them off as that throws off the alignment for some reason and run it in letterbox integer scale.


My image points are okay and this occurs with tiled background objects too (ie the bricks in my example image) where the image point defaults to the top-left.

lamar wrote:Oh and check your layout and view scale. They need to be in even increments of 16 pixels like 640x640 otherwise the raster will miss pixels and that would explain why the horizontal lines are missing.


My game's native resolution is 1280x720 so that shouldn't cause any problems, although it looks weird both in window and fullscreen. How would one set the view scale to something divisible by 16?

Thank you for your detailed reply, it's encouraging to know somebody has fixed this problem, although I haven't found the fix I need yet :)
Image



Coming soon on Steam!
B
16
S
9
G
3
Posts: 201
Reputation: 3,460

Post » Sun Jan 22, 2017 3:31 pm

mikehive wrote:
lamar wrote:It is the horizontal lines that are disappearing. I had that happen in a game and if I remember correctly I fixed it by having the editor image at original size and then setting the image to the size I want in the settings and you may have to play with those settings to maintain the proper ratio.


This sounds promising, could you elaborate? I'm not completely following you. The settings for the sprite object? Everything is currently in the layout editor at 1:1 scale, with the entire layout enlarged by 1.8 scale in events. What do I change, without rebuilding my entire game?

lamar wrote:Also recheck your image points have not slipped out of line and if there is any white or light gray borders around images crop them off as that throws off the alignment for some reason and run it in letterbox integer scale.


My image points are okay and this occurs with tiled background objects too (ie the bricks in my example image) where the image point defaults to the top-left.

lamar wrote:Oh and check your layout and view scale. They need to be in even increments of 16 pixels like 640x640 otherwise the raster will miss pixels and that would explain why the horizontal lines are missing.


My game's native resolution is 1280x720 so that shouldn't cause any problems, although it looks weird both in window and fullscreen. How would one set the view scale to something divisible by 16?

Thank you for your detailed reply, it's encouraging to know somebody has fixed this problem, although I haven't found the fix I need yet :)


There in lays the problem. If you have a bunch of graphics set 1:1 and they are all dropping horizontal pixels it would be a major chore to rework each one.

The scaling will need to be 1:1 or it will continue to happen.

You could select all the objects and use the scale control to scale them down and see if that fixes it.

If you set your window and view to an odd number not divisible by 16 or 8 it will throw off the raster making it drop pixels in some games with very fine detail. It sounds like you would be OK but fiddle with it and see if it helps.

I am using scaling in my project now and I found it better to use whole integers so try a scale of 2 instead of 1.8 and see if that works.
Banned User
B
23
S
6
G
58
Posts: 1,229
Reputation: 34,540

Post » Sun Jan 22, 2017 6:54 pm

Aha! Progress!!

Image

Turns out I had two problems going on that were independently causing graphics bugs. I'd already tried setting the scale to an integer of 2 but had noticed there was still some weirdness in my tiled backgrounds so assumed that that wasn't the solution. Turns out that it was the way to go, and that I'd stupidly also made some of my tiled backgrounds at weird sizes, so they weren't tiling properly! Some of these graphics I made years ago when I was learning C2 and I guess I made them wrong - that brick texture was like 31x35 or something?? Wtf was I thinking? I remade it to be 32x32 and guess what, it displays properly now -_-

Thank you for your help! I guess I'm going to have to adapt my game to the 2-scale now - it shouldn't be too drastic of a change, just a few levels need to be reworked but that's ok :)

EDIT: Oh, and switching to Integer Scale mode was essential.
Image



Coming soon on Steam!
B
16
S
9
G
3
Posts: 201
Reputation: 3,460

Post » Sun Jan 22, 2017 7:04 pm

mikehive wrote:Aha! Progress!!

Image

Turns out I had two problems going on that were independently causing graphics bugs


Right on and looks great!

I have done that enough times to know the frustration. Now I set all my tiles and sprites and check the scale before I get too far into a design.

Looking forward to seeing the finished game!
Banned User
B
23
S
6
G
58
Posts: 1,229
Reputation: 34,540

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: Glyfos, jefftrier and 5 guests