plasma bug with zoom

For questions about using Classic.

Post » Thu Nov 01, 2012 7:13 am

Hello!
I have a game that I zoomed in.And when I do it the plasma doesn't work.What should I do?
B
14
S
4
G
2
Posts: 91
Reputation: 2,390

Post » Thu Nov 01, 2012 11:07 am

You'll have to tell a bit more about the problem. I didn't run into any trouble while trying to replicate the issue in this cap.

CC r2 cap:
plasmazoom1.cap

One thing that did come into mind though was that I reckon that like all the other objects plasma doesn't render if its out of screen (meaning its coordinates, in my cap it's partially out of screen due to the zooming), so maybe your problem is related to that?Zotged2012-11-01 11:08:18
B
11
S
2
G
3
Posts: 100
Reputation: 2,150

Post » Thu Nov 01, 2012 3:44 pm

...
It's so strange...
Why doesn't it work?
It's something wrong in that layout.I used your way in other layouts and not any problem.But in that layer when I wheel up and the display zooms in,the plasma disappears.And again when zoom becoms normally,the plasma appears.
Why?
B
14
S
4
G
2
Posts: 91
Reputation: 2,390

Post » Sat Nov 03, 2012 10:24 am

Welcome to my world

Zooming and plasma doesn't seem to work if you use multiple colour filters for your plasma effect. They all get displaced, sometimes moving off screen, instead of layering on top of each other. Try massively increasing the size of your plasma objects and you'll see what I mean. I tried to use plasma for waterfalls but had to abandon that idea when zooming screwed up my plasma effects.

I think there is a workaround you can use that someone suggested (I'll try to find the link when I'm back on my computer, using an iOS device atm - you could try searching the forum for it) but it's not a quick solution. Might be best to either abandon the zoom function or achieve the effect you're after without plasma.

EDIT: Here you go. Hope it helps -Silver-2012-11-03 11:40:24
B
15
S
7
G
7
Posts: 250
Reputation: 5,298

Post » Fri Nov 23, 2012 3:09 pm

thank you silver!
It helped me!
B
14
S
4
G
2
Posts: 91
Reputation: 2,390


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 5 guests