Page 2 of 2

Re: Platform Behavior - Not detecting landing on Slopes

PostPosted: Thu Jun 05, 2014 2:37 pm
by Ashley
@Ldk - I see what you mean now, it doesn't correctly register floor detection in some cases which also affects the animations. I think this is fixed for the next build, please confirm when r171 is out (should be today hopefully).

Re: Platform Behavior - Not detecting landing on Slopes

PostPosted: Thu Jun 05, 2014 2:50 pm
by Ldk
@Ashley
Awesome. Thank you. Will test once the new build is available

Re: Platform Behavior - Not detecting landing on Slopes

PostPosted: Thu Jun 05, 2014 8:43 pm
by Ldk
@Ashley

It did fix it however it introduced a new bug.
Tested using my game and also the same capx i posted here.

The platformer cannot always jump while running up a slope. Even if the slope is at a very slight angle.
However running down the slope it can still jump.

What i found in the debugger
The platformer behavior stays on moving and on floor.

The sprite triggers "falling" animation. This makes me think that perhaps for a fraction of a microsecond the behavior "jumped" but switched immediately to on floor which then triggers the landing animation.

I really appreciate all your assistance and hard work.

Thank you.

Re: Platform Behavior - Not detecting landing on Slopes

PostPosted: Thu Jun 05, 2014 11:30 pm
by Ashley
@Ldk - could you make a separate bug report with full details again including reproduction .capx?

Re: Platform Behavior - Not detecting landing on Slopes

PostPosted: Fri Jun 06, 2014 4:56 am
by Ldk
Will do