Platform Behavior - Not detecting landing on Slopes

Bugs will be moved here once resolved.

Post » Thu Jun 05, 2014 2:37 pm

@Ldk - I see what you mean now, it doesn't correctly register floor detection in some cases which also affects the animations. I think this is fixed for the next build, please confirm when r171 is out (should be today hopefully).
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,454

Post » Thu Jun 05, 2014 2:50 pm

@Ashley
Awesome. Thank you. Will test once the new build is available
B
8
S
2
Posts: 163
Reputation: 1,115

Post » Thu Jun 05, 2014 8:43 pm

@Ashley

It did fix it however it introduced a new bug.
Tested using my game and also the same capx i posted here.

The platformer cannot always jump while running up a slope. Even if the slope is at a very slight angle.
However running down the slope it can still jump.

What i found in the debugger
The platformer behavior stays on moving and on floor.

The sprite triggers "falling" animation. This makes me think that perhaps for a fraction of a microsecond the behavior "jumped" but switched immediately to on floor which then triggers the landing animation.

I really appreciate all your assistance and hard work.

Thank you.
B
8
S
2
Posts: 163
Reputation: 1,115

Post » Thu Jun 05, 2014 11:30 pm

@Ldk - could you make a separate bug report with full details again including reproduction .capx?
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,454

Post » Fri Jun 06, 2014 4:56 am

Will do
B
8
S
2
Posts: 163
Reputation: 1,115

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest