Platform object sinks into solid ground (Bug?)

Get help using Construct 2

Post » Mon Sep 17, 2012 4:27 pm

Hello everyone,
yesterday I started making my first platform game prototype in C2 103.2 (freeware edition). Everything went really well until suddenly I stumbled upon a bug so terrible it makes me want to stop and go back to Construct Classic and never touch C2 again.
This is what happened:

I made this square-shaped sprite and gave it platform behaviour. Then I let it jump around on solid blocks - just to see if it worked. And it worked. However when the platform object landed on the ground it would sometimes sink into the solid object, as can be seen on picture #2. Completely at random. So sometimes the bottommost line of pixels of the platform object would be hidden behind the floor... and sometimes it wouldn't. How on earth is this possible?
This even happens in other games like for instance "Dual Custody" on the Scirra Arcade. Is there really no workaround for this horrible and pixel-art-defacing bug?
I was only one click away from buying C2 yesterday evening. And now I'm so glad I didn't do it. I guess maybe I should give it another year or so.wiimote2012-09-17 16:32:11
Posts: 24
Reputation: 2,800

Post » Mon Sep 17, 2012 4:49 pm

i believe your problem comes from fact that C2's platforms behavior is not designed for small sprites
read this and this.

custom platform behavior with loops may be way to go, or somekind of custom collision detection...podpathos2012-09-17 16:50:33
Posts: 96
Reputation: 1,583

Return to How do I....?

Who is online

Users browsing this forum: CrudeWall, makkancs, Onlive122, Radulepy, Tobik and 14 guests