Platformer HELP :C

For questions about using Classic.

Post » Fri Jun 18, 2010 11:21 am

This happens to be about 50% of the time I work with the platformer behavior, Its weird though this time because for the first hours I worked with it, it never messed up once..
Once I test the game, the player falls through the floor out of nowhere.
It doesn't change anything when I toggle any of the solid settings and etc, It just messes up.

Any Help?
B
2
S
2
G
3
Posts: 140
Reputation: 1,530

Post » Fri Jun 18, 2010 11:39 am

This happens to me too. Not that often though and usually only when debugging the layout.

Don't think it's your events just a small Construct bug. Try placing your character/hitbox just above your solids in the layout editor that used to help for me.
B
46
S
23
G
7
Posts: 459
Reputation: 6,763

Post » Fri Jun 18, 2010 2:27 pm

I tried everything I could but nothing seemed to fix my problem..
So I restarted and made new sprites and etc.
Once I got to the point of setting my collision mask to rectangle matching the size of my character,
I saved, then hit set collision to all animations library w.e
and It didn't work, the sprites each still had there own collision mask,
once It stopped being separate collision masks,
The character continued to fall through the ground..

ZOMG
B
2
S
2
G
3
Posts: 140
Reputation: 1,530

Post » Fri Jun 18, 2010 4:18 pm

Try thicker ground. Construct is rather glitchy when it comes to collisions.
B
2
S
2
G
3
Posts: 193
Reputation: 1,636

Post » Fri Jun 18, 2010 7:10 pm

So I just kept setting a red rectangle as the collision mask over and over until it worked and now the character's feet are in the ground...
Everything worked great except that one thing.. wtf! :P
B
2
S
2
G
3
Posts: 140
Reputation: 1,530

Post » Fri Jun 18, 2010 7:17 pm

What version of Construct?
Image Image
B
161
S
48
G
90
Posts: 7,356
Reputation: 66,767

Post » Fri Jun 18, 2010 7:25 pm

Im using the newest version, marked unstable :o
should I switch back to the stable version until a more stable release?
B
2
S
2
G
3
Posts: 140
Reputation: 1,530


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 6 guests