Platformer (Please Check for Bugs!)

Show us your completed creations made in Construct 2

Post » Tue Dec 20, 2011 2:29 am

(FIXED)I'm having trouble, once you get to the second screen, all the ledge helpers are out of place. I have the detector and helpers visible for observation. In C2 frame editor itself, they're placed properly, on the ledges. What could cause this? EDIT: This has been fixed!

WILL BE ADDING MORE POWER UPS BY THE END OF THE WEEK and hopefully I can get Projectiles and Meele weapons ready as well!

Controls are as follows:

Shift, Z, X, Space, direction keys

Click to Play Example

Please scroll down to see updates to the game.

ALL BUGS SHOULD BE FIXED NOW, PLEASE TEST IF YOU WOULD!

Space = Jump
Space while Jumping = Jump Boost
Up while Jump Boost = Jet Pack
(either up/down style or upgrade for faster up/down left/right)
Space while Jet Pack = Turn off Jet Pack

Down = Crouch
Down in water = Swim (with Flippers)

Left/Right = Walk
Z = Meele (Not ready)
Hold Z and Left/Right = Run
X = Weapon (Not ready)

Shift (next to box) = Grab, left/right to pull. Pushing a block doesn't require grabbing it.
------------
(fixed)Remember, I'm having trouble with the ledge helpers not working properly on the SECOND FRAME.
------------


Thank you,
Rory

Update @ 2:31 AM
BTW: You have to get three items on the first frame to exit to the next. The exit from frame one is in the top right corner.

----------------

Update @ 5:55 AM
Updated, fixed swimming, added power ups for life and "steam" power.

You now lose steam when using your items (double jump is part of the steam power system) so be careful when jetting around.

See original link.

----------------

Update @ 9:06 AM
Current update now has a different method of using the jet pack feature. It has been replaced with 8-direction movement.

----------------

Latest update fixes a general error where the ledges from the previous frame were appearing in the new frame.

----------------

Last update only removed the ledges but the second frame wouldn't load the ledges where they are. IE: You get to frame 2 and they're all gone (because of END OF FRAME = destroy ledges). PLEASE HELP ME WITH THIS!!!!

----------------

It appears after the crash yesterday, it had set all the ledges to global-yes, so that was the problem I was having. Check link again to play.

----------------

Update: Added idle animations.roracle2011-12-20 19:29:45
B
24
S
6
G
6
Posts: 255
Reputation: 3,649

Post » Wed Dec 21, 2011 3:12 pm

discovered a bug.
when the character is in the water. i did a jump with the space bar.
the character state revert back to where he is on the land. I can sprint and jump as usual.
B
18
S
3
G
3
Posts: 15
Reputation: 3,191

Post » Wed Dec 21, 2011 6:48 pm

Check it now. I changed a few things.
B
24
S
6
G
6
Posts: 255
Reputation: 3,649

Post » Wed Dec 21, 2011 11:06 pm

Looks good so far. I was seeing 1 bug where, when hanging on a wall, I press up to climb up and the character drops down for a brief second before popping back up to the ledge and climbing up.

For the finished product, to would be nice to have in game prompts teaching the user how and when to use the double jump, jet pack, etc... At least for the first level.
B
38
S
12
G
11
Posts: 328
Reputation: 7,706

Post » Thu Dec 22, 2011 2:51 pm

Hey Frag, thanks for checking that out. I think the "drops down for a brief second" thing is happening because of a general lag issue as the image points are set appropriately and plays properly.

Also, I've been working by myself on this for three and a half weeks straight and will (eventually) get around to on screen display of controls. Which is why I put them on the original post here.

Now, I've updated the game with higher res character sprites (and no longer invisible outline) and put in a few particle effects when using the steam or when swimming. (Which will most likely be updated later, this is a bug test, not an artistic critique, that will come later. )
B
24
S
6
G
6
Posts: 255
Reputation: 3,649


Return to Completed Creations

Who is online

Users browsing this forum: No registered users and 4 guests