Playing music using X2Audio

For questions about using Classic.

Post » Thu Nov 11, 2010 2:48 am

I tried to go back to Tom Mahler's X2Audio video but he's taken it off his site and the link is broken, cause much expressive primal rage.

I formatted my PC about a month ago and I lost all track of Construct. Today I re-installed it and am continuing to work on my GT1 clone. However, I've forgotten how to play music through X2Audio.

I have X2 added as an object and I've imported my music into the Music tab of Resources.

When I go to create an event "Start of layout -> Play music from file" it gives me something about AppPath and Filename. When I go to go "Start of layout -> Play music from resource" there is no file in the drop down list.

I'm pretty P.O'ed and I was wondering if there was any back-up of Mr. Mahler's video anywhere or if someone can just tell me what I'm doing wrong.
B
1
G
2
Posts: 8
Reputation: 641

Post » Thu Nov 11, 2010 3:00 am

Don't add it as a resource. Put it in the directory of your .cap and "play music from file" > apppath&"filename.mp3"

With the sounds out of the .cap, it makes them easier to change/tweak if necessary.
B
25
S
3
G
6
Posts: 1,197
Reputation: 5,620

Post » Fri Nov 12, 2010 2:56 am

If you want to have the sound/music files contained inside the game instead of in the directory, you can do it the exact same way you tried to.
The only thing is that you must add them to 'Files' ressources instead of 'Sounds' or 'Music' ones.
B
11
S
3
G
3
Posts: 206
Reputation: 2,379


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 5 guests