Playing Particle Effects and Sounds while Timescale = 0

For questions about using Classic.

Post » Tue Nov 23, 2010 10:30 am

I have a Particles object which I want to be always "animated" even when Timescale = 0. Is there a way to do this?
Also, is there a way to make a specific channel (of the XAudio2 object) ignore Timescale? Unchecking "Timescale audio" affects all channels, but I want to reserve only 1 channel to play when Timescale = 0.
Thanks.
B
5
S
1
G
3
Posts: 59
Reputation: 993

Post » Tue Nov 23, 2010 1:00 pm

I'm afraid there is no way for the particles, apart from doing you own particle generation with sprites through events.

Controlling the audio channels is a lot more easy. Just uncheck "Timescale audio", then select all the channels that you want to be affected by timescale, and set them to a frequency fitting timescale.

Example:[code:36jmw24x]+ System: For "" from 1 to 5
-> XAudio2: Set channel LoopIndex frequency ratio to TimeScale
[/code:36jmw24x]
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242

Post » Tue Nov 23, 2010 2:25 pm

Oh, so for the 64 available audio channels, I can just loop from 1 to 63 to make them "normal" again, and just channel 64 will not follow timescale.
B
5
S
1
G
3
Posts: 59
Reputation: 993

Post » Tue Nov 23, 2010 2:42 pm

Yes.

Just do the loop whenever you change the time scale.
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests