Please have a look at my code

Get help using Construct 2

Post » Tue Dec 16, 2014 9:19 pm

This is what I have right now and the player climbs ladders fine - however when moving down the stairs he isn't looping the animation of moving while when moving up the ladder animation plays fine... am I missing something or can anyone see something wrong?
You do not have the required permissions to view the files attached to this post.
Need Sprites For Your Next Project?
100% Vector Animated Sprites
B
8
S
2
Posts: 170
Reputation: 1,086

Post » Tue Dec 16, 2014 9:33 pm

Could be a couple of things.. I'm not 100% sure on this (I would have to see capx to test) but I would try the following:

I think "Set isClimbing to True" on the Up Arrow events should be toggle isClimbing instead.

And for Down arrow event concerning animations, instead of "play from beginning" try "play from current frame"
Image Image Image
B
63
S
19
G
6
Posts: 325
Reputation: 7,994

Post » Tue Dec 16, 2014 9:59 pm

what you mean

"I think "Set isClimbing to True" on the Up Arrow events should be toggle isClimbing instead."
Need Sprites For Your Next Project?
100% Vector Animated Sprites
B
8
S
2
Posts: 170
Reputation: 1,086

Post » Tue Dec 16, 2014 10:27 pm

desjardins2014 wrote:what you mean

"I think "Set isClimbing to True" on the Up Arrow events should be toggle isClimbing instead."


Scratch that, my mistake. I missed it the first time, I see now that they are both set to True.

I have a feeling that it's your animation control. Try "play from current frame" For your Down arrow animation

I attached a screen of a climbing I did a while ago. May be of some help.
You do not have the required permissions to view the files attached to this post.
Image Image Image
B
63
S
19
G
6
Posts: 325
Reputation: 7,994


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 7 guests