[Plugin] Flurry Analytics

Post your completed addons to share with the community

Post » Fri Oct 10, 2014 4:18 pm

@federer365 Hmm, it should work on Crosswalk. Are there permissions you might need to enable?
Moderator
B
72
S
14
G
11
Posts: 900
Reputation: 11,940

Post » Tue Nov 04, 2014 10:41 pm

@thehen - Hi!! First of all: tx for dedicating the time buiding this plugin, i appreciate it!

I was going to read the SDK but it looks like there is no more public access: https://www.dropbox.com/s/rpimc1b5qxwwg ... README.pdf

cheers, Bruno!
B
9
S
2
Posts: 52
Reputation: 1,360

Post » Tue Nov 11, 2014 2:28 pm

anyone was able to use it with crosswalk?

tx!
B
9
S
2
Posts: 52
Reputation: 1,360

Post » Tue Nov 18, 2014 11:14 am

Hi @thehen

I tried this in CocoonJS but it seems not to work.
I copied all the files into the .zip and compiled the project using the latest CocoonJS plugin from git and the 2.1 compiler.

The isFlurryLoaded condition returns true, but events will not get tracked.
I tried it in the launcher and a compiled project, but no events got tracked by flurry (even after days of waiting).

Any ideas ?
Thanks !
B
12
S
5
G
1
Posts: 36
Reputation: 2,050

Post » Fri Dec 26, 2014 10:59 am

KFC wrote:So I finally had time to sit down and figure out what was causing my flurry problem.

The way I logged parameter events was I would add a new key in my dictionary and add a value from a variable, current level, the number of times the user restarted the level or something similar.
As it turns out flurry wouldn't display events with parameters that only have numbers as their value, so I had to add a text string for the events to be registered and displayed correctly.


Good job KFC, i had the same problem.
Image
B
30
S
5
G
1
Posts: 125
Reputation: 3,226

Post » Mon Dec 29, 2014 2:52 pm

Hello,

A user reported an issue some days ago regarding a problem of the plugins and we realized that the real problem was that this plugin is using a deprecated version of our code. The plugin and the prelude were updated the 5th of November. Right now, our C2 plugin uses the 3.0.5 version of the JS plugins. This is the new documentation:
http://doc.ludei.com/3.0.5/Cocoon.App.html
As you can see, the main change is that now CocoonJS is called just Cocoon and some methods now are shorter. In addition, there are new namespaces, so it can be that a method is now in another namespace more suitable to its function. This means this won't work unless all the files are edited to use the latest version of our code.
Here are the JS plugins files that you need to replace:
https://github.com/ludei/cocoonjs-plugins
However, this code is already contained in the prelude, so maybe there is a way of using it instead of pasting these files again.

Regards.
B
9
S
4
G
4
Posts: 383
Reputation: 3,616

Post » Wed Dec 31, 2014 10:57 am

I was one of the users with this issue. Any chance this Fluury plug-in can be updated to be compliant with Cocoonjs?

Thanks,
Mike Parent
B
49
S
9
G
4
Posts: 426
Reputation: 7,071

Post » Sun Jan 18, 2015 9:33 am

When I am using the Flurry Plugin it crashes the app in Android and it gives the following error while loading the webview.html when the Flurry plugin is getting initiated,
Code: Select all
 CocoonJS['App']['loadInTheWebView']( "webview/webview.html" );


java.lang.IllegalStateException: The specified child already has a parent. You must call removeView() on the child's parent first.

If it comment above webview.html loading line then the App works but flurry is not working,

Another interesting point noted is that if the app is zipped and used via the CustomCocoonJS Launcher then it crashes , but If i load the files from the webserver after exporting and unzipping it as separate files it then it seems to work fine. Looks to me like a timing issues, So , I am not sure what needs to fixed, Also Note the same code works with iOS without any issues. Please help !
Anyhelp in this matter is greatly appreciated.
B
16
S
4
Posts: 248
Reputation: 2,267

Post » Thu Mar 19, 2015 10:56 pm

Thanks
B
7
S
1
Posts: 10
Reputation: 548

Post » Thu Jul 16, 2015 6:06 pm

Has anyone used this plugin recently? I tried the test project and using it in my own project without any luck so far.

I know the plugin hasn't been updated in awhile but I took a look at the release notes and the mobileSDK hasn't been updated in 2 years. So that shouldn't be the case.

Thanks much!
B
52
S
13
G
7
Posts: 147
Reputation: 6,800

PreviousNext

Return to Completed Addons

Who is online

Users browsing this forum: No registered users and 1 guest