[PLUGIN] Magicam for C2(Alpha 6.5 1/8/14)

Post your completed addons to share with the community

Post » Wed Jan 08, 2014 9:04 am

Ah yes that's in it quite often in my game.
B
12
S
4
G
1
Posts: 137
Reputation: 1,519

Post » Thu Jan 09, 2014 1:59 am

I've got a fresh release that fixes a couple of bugs which I've found since the last version. I'd strongly recommend upgrading to this version even in the absence of new features.

Alpha 6.5 release notes:

Download Magicam Alpha 6.5 for Construct 2 (Includes example)

(FIX) Re-added the Un-follow object action after it was added in alpha 3 and then mysteriously vanished in every subsequent version.

(FIX) Zoom bounds would not be saved/loaded with the state of the game.

@mapmerry - Be sure to download this and let me know if it works, although I have a good feeling about it.

As usual, please leave comments, requests, bugs, etc. if you have them.
Moderator
B
97
S
36
G
19
Posts: 1,584
Reputation: 17,692

Post » Thu Jan 09, 2014 9:12 am

This works great thanks. No more errors.
B
12
S
4
G
1
Posts: 137
Reputation: 1,519

Post » Fri Jan 17, 2014 4:24 am

UN-FOLLOW OBJECT!
thanx!!
B
12
S
4
G
1
Posts: 2
Reputation: 1,061

Post » Thu Jan 30, 2014 8:28 am

If I create a camera with the same name as a previously made camera, will it replace the original?

I was struggling to get it to refresh when a followed object is deleted.
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
68
S
8
G
6
Posts: 929
Reputation: 9,356

Post » Thu Jan 30, 2014 9:14 am

Also, in my project, in order to get a smoother camera track I have an object that always lerps to the camera position.

The camera is tracking 4 objects all at once, so trying to keep the camera in between all of them. When one of the objects is destroyed, I tell it to un-follow that object.

It seems that if an object that is being followed is destroyed, you can not use un-follow. Looks like you have to unfollow it before it is destroyed, but that's awfully hard to do when the object is part of a much larger family.

Therefore, I have it set up so that it says "If object count = 0 unfollow object". This doesn't appear to work well.

The only way I can get it to work is to create a new camera over(?) the other one. However, what this does it causes a slight shudder when the camera changes.

Is there a way to have the camera active, and tracking the other objects, but without the scroll to actually following the camera point?
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
68
S
8
G
6
Posts: 929
Reputation: 9,356

Post » Fri Jan 31, 2014 12:33 am

Sorry about so many posts, but I do not understand the zoom function. It appears to be very jerky indeed, and no matter how much I change the lower and upper values, I'm unable to set the zoom so that it never goes below 100%, or that it only ever zooms out to 50%.

Even in the example provided it's quite jerky. I'd like to incorporate lerp, but I can't see where to add it.
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
68
S
8
G
6
Posts: 929
Reputation: 9,356

Post » Fri Jan 31, 2014 2:30 am

Hi there,

Love the plugin but I'm having some issues with setting an upper and lower zoom limit. I'm probably just being an idiot but I would like it so it zooms out to contain my characters but then doesn't zoom in too close when they get closer to each other.
Any changes I make to lower limit zoom from -1 cause it to zoom in to like a 10x10 pixel screen. Am I just using it wrong?

Thanks for the plugin!

Charlie
B
7
S
1
Posts: 20
Reputation: 686

Post » Fri Jan 31, 2014 4:35 am

@AnD4D - The plugin is setup such that if you attempt to create a camera with the same name as a pre-existing one, then a new camera will not be created.

About the issue with not being able to unfollow destroyed objects, this is something I'll have to fix, but I'll set it up in such a way that destroyed objects are automatically unfollowed.

On the last issue, I've never noticed any jerkiness with any of the zoom features, however, I don't have it set up to use the lag value supplied for following, so I'll look into changing that. As for the bounding values, I'll explain that next, as this sounds related to both of your problems.

@cazbah - It sounds like you're either mixing up your upper and lower bounds, or you're using the wrong scale. It must be understood that when zoomed in, the zoom value is going to be larger that when zoomed out. Second, the scale is such that the value you give acts as a multiplier on the base zoom value of 100%, so a value of 1 would set zom to 100%, while a value of 2 would set it to 200%, a value of 0.5 would make it 50%, etc. Thus, if you wanted to, say, zoom out no farther than 50% and zoom in no more than %200, you would set the lower and upper bounds to 0.5 and 2, respectively.

I realize I wasn't entirely clear in the descriptions for those parameters as to how it's laid out, and for that I apologize.

Let me know if you guys run into anymore troubles. I don't have an ETA on the next version as I've been incredibly busy with school lately, but I'll do my best to have it out in a timely manner.
Moderator
B
97
S
36
G
19
Posts: 1,584
Reputation: 17,692

Post » Fri Jan 31, 2014 5:03 am

Thanks a lot buddy that worked perfectly.

I just checked the page thinking "there is no way they will have responded yet." but you took the time to explain it to me in a clear way.

You're amazing, thanks again,

Charlie
B
7
S
1
Posts: 20
Reputation: 686

PreviousNext

Return to Completed Addons

Who is online

Users browsing this forum: No registered users and 1 guest