Plugin SDK 0.99.3

Forum for plugin, effect and behavior programmers. Please use the Help & Support forum for help using Construct.

Post » Fri Jun 19, 2009 11:57 pm

[size=150:1yp0qu76]Download Plugin SDK 0.99.3 now[/size:1yp0qu76]

Sorry it's late!

Changes in this SDK:
- The SDK now reflects the large codebase changes that happened in the 0.99 release. As a result, parts of the SDK have changed. Compiled plugins are binary compatible (meaning plugins built with old SDKs still work with 0.99+), but some changes may be needed for old plugins to build again in the 0.99.3 SDK. Anything that no longer works in this SDK has deprecated_ prepended to it, so the compiler will tell you that the deprecated functions no longer exist.
- The SDK includes the new templated vector math functions in use in 0.99+ (in the cr:: namespace) as well as new definitions for the new renderer. Old rendering functions in VRuntime are deprecated; rendering is now performed by a new interface (IRenderer) pointed to by the 'renderer' member of CRunObject. I don't think this affects any third party plugins because I haven't seen any that use the renderer yet.
- The object filter (colour tint + opacity) has been moved. It used to be a D3DCOLOR in info.filter (now renamed info.deprecated_filter); it is now a cr::color in info.pInfo->filter.
- There are a couple of new VRuntime functions.

I don't think existing third party plugins will suffer too much from this - they should only need small changes. If you need any help let me know and I'll try sort it out. Note that the includes in stdafx.h have changed and if you don't update these your plugin won't compile and will give a lot of errors: if you haven't changed stdafx.h, just paste in the new one from the new SDK, or look at the new headers and typedefs and paste them in.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Sat Jun 20, 2009 12:02 am

whoa, you're double awesome today ashley!

question
so plugins made with this will [u:31ov83l5]not[/u:31ov83l5] work in 98 construct, right?
Spriter Dev
B
87
S
21
G
12
Posts: 3,240
Reputation: 16,461

Post » Sat Jun 20, 2009 3:27 pm

They'll still work in older versions too, because they're binary compatible. But any features which have changed (the renderer, filter etc) won't work in older versions, but I don't know of any plugins this would affect.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Sun Jul 11, 2010 10:16 am

-_- atl.
B
2
S
1
G
4
Posts: 64
Reputation: 1,328

Post » Fri Jul 30, 2010 7:45 pm

Is the SDK fully compatible with 0.99.91? Just asking since it's over a year old.
B
17
S
6
G
6
Posts: 113
Reputation: 4,161

Post » Sat Jul 31, 2010 2:03 am

[quote="Trevor10":10histt7]Is the SDK fully compatible with 0.99.91? Just asking since it's over a year old.[/quote:10histt7]
Nothing major has changed in Construct since this version of the SDK was released, so it's still 100% compatible.
Moderator
B
97
S
36
G
19
Posts: 1,584
Reputation: 17,692

Post » Thu Jan 19, 2012 7:03 pm

bump for sticky
Spriter Dev
B
87
S
21
G
12
Posts: 3,240
Reputation: 16,461

Next

Return to Construct engineering

Who is online

Users browsing this forum: No registered users and 0 guests