[PLUGIN] "Share" Popup Fixed (Fb, G+, Twitter etc.) V3.5

Post your completed addons to share with the community

Post » Fri Sep 19, 2014 9:52 am

I seem to be having a little trouble with the share image to facebook function.

This is my setup, is this as expected?

Image

In Firefox, upon clicking share, a new tab opens in the browser, the tab title saying "Connecting..." and the helper text at the bottom of the screen saying "Waiting for Facebook...". After about 30 seconds, it times out and leaves a blank screen.

In Chrome, upon clicking share, a new window opens that tries to connect to facebook, but ends up failing. Screengrab below:

Image

On Internet Explorer, I was able to proceed to Facebook and post something, however no image was displayed:

Image

Clicking on the link takes me to the following URL which is stuck on an endless load loop:

Code: Select all
URL REMOVED


Firefox Version 32.0.1.
Chrome Version 35.0.1916.153
Internet Explorer Version 11.0.9600.17278

Let me know if you need any further information! Tried to be as thorough as I could.

Thank you.

Edit: Update:
I also tried this using R0J0hound's Paster plugin as an alternative to the CanvasSnapshot method, and incurred the same result on all three browsers. Thought this was a relevant point to add.

http://goo.gl/iwYgy4 for the CanvasSnapshot method.
http://goo.gl/4lBhL7 for the Paster method.
Last edited by angellondon on Fri Sep 19, 2014 11:32 am, edited 1 time in total.
B
7
S
1
Posts: 61
Reputation: 588

Post » Fri Sep 19, 2014 11:16 am

angellondon wrote:I seem to be having a little trouble with the share image to facebook function.

This is my setup, is this as expected?

Image

In Firefox, upon clicking share, a new tab opens in the browser, the tab title saying "Connecting..." and the helper text at the bottom of the screen saying "Waiting for Facebook...". After about 30 seconds, it times out and leaves a blank screen.

In Chrome, upon clicking share, a new window opens that tries to connect to facebook, but ends up failing. Screengrab below:

Image

On Internet Explorer, I was able to proceed to Facebook and post something, however no image was displayed:

Image

Clicking on the link takes me to the following URL which is stuck on an endless load loop:

[code][/code]

Firefox Version 32.0.1.
Chrome Version 35.0.1916.153
Internet Explorer Version 11.0.9600.17278

Let me know if you need any further information! Tried to be as thorough as I could.

Thank you.

Edit: Update:
I also tried this using R0J0hound's Paster plugin as an alternative to the CanvasSnapshot method, and incurred the same result on all three browsers. Thought this was a relevant point to add.

http://goo.gl/iwYgy4 for the CanvasSnapshot method.
http://goo.gl/4lBhL7 for the Paster method.


You are doing it a little bit wrong.
This is what you need to do :

OnCanvasSnapshot -> Upload CanvasSnapshot.
On Upload finished -> Share via facebook -> Share.LastData

This should work, checkout the V3 .capx example for upload.
B
31
S
10
G
2
Posts: 310
Reputation: 5,516

Post » Fri Sep 19, 2014 11:20 am

Ahhh thank you! I will try this now.
B
7
S
1
Posts: 61
Reputation: 588

Post » Fri Sep 19, 2014 11:22 am

angellondon wrote:Ahhh thank you! I will try this now.


You need to have a PHP hosting to do the upload part.

And to download the screenshot you can do :

Browser Object -> Invoke Download -> canvassnapshot
B
31
S
10
G
2
Posts: 310
Reputation: 5,516

Post » Fri Sep 19, 2014 3:53 pm

Just to let you know that I got it working just fine, now! Thanks for your help with troubleshooting! :) it was only not working due to my incorrect setup, as you said.
B
7
S
1
Posts: 61
Reputation: 588

Post » Fri Sep 19, 2014 5:59 pm

angellondon wrote:Just to let you know that I got it working just fine, now! Thanks for your help with troubleshooting! :) it was only not working due to my incorrect setup, as you said.


Great!
B
31
S
10
G
2
Posts: 310
Reputation: 5,516

Post » Mon Sep 22, 2014 9:13 am

Hello again!

Trying to modify this a little, so that I can share a cropped image. I am using a plugin named Paster to do this, which outputs .png files.

This doesn't seem to be working as smoothly with the Share plugin, however.

I modified createimg.PHP to create png files instead, and checked the image it created on our server in order to make sure it created it correctly, which it did. However, upon sharing to the user's Facebook wall, no image is displayed.

My question is: can Share currently only support JPEGs? If so, I would like to request an extension to also support PNGs :)

Thank you.
B
7
S
1
Posts: 61
Reputation: 588

Post » Mon Sep 22, 2014 10:20 pm

Hello,

I just purchased your plugin a few hours ago and recieved two e-mails from PayPal: One confirming that the money has been send and one confirming that the money has been recieved. None of those e-mails contained a download link for the addon. Will I get another e-mail or did something go wrong somehow? I can prove payment of course.
B
13
S
3
G
1
Posts: 91
Reputation: 1,477

Post » Mon Sep 22, 2014 10:39 pm

CreativeMind wrote:Hello,

I just purchased your plugin a few hours ago and recieved two e-mails from PayPal: One confirming that the money has been send and one confirming that the money has been recieved. None of those e-mails contained a download link for the addon. Will I get another e-mail or did something go wrong somehow? I can prove payment of course.


Yes you will get 3th email from me soon as possible. (I know your mail) Sorry for the delay.
B
31
S
10
G
2
Posts: 310
Reputation: 5,516

Post » Mon Sep 22, 2014 11:21 pm

Awesome!
B
3
Posts: 5
Reputation: 183

PreviousNext

Return to Completed Addons

Who is online

Users browsing this forum: No registered users and 7 guests