[PLUGIN] Video

Post your completed addons to share with the community

Post » Thu Dec 13, 2012 12:03 am

@RoSecco

Sorry, I don't have ipad to test the problem.

@Pode , do you have any idea about playing video on ipad? rexrainbow2012-12-13 04:14:51
B
97
S
22
G
176
Posts: 4,109
Reputation: 103,021

Post » Fri Dec 14, 2012 10:42 am

@RoSecco @rexrainbow : on ipad/iphone (ios in general), the <video> can't work like that. In fact, if you want to launch a video, it's going to display in fullscreen, with the controls of the platform (meaning you can't style them, you can't autoplay the video, and you don't have any info about when it's finished).
B
33
S
9
G
6
Posts: 709
Reputation: 6,704

Post » Mon Dec 17, 2012 3:02 pm

Hi,

I've got some problems with this plugin when I try to export the project and open it on firefox. the video doesn't play and I don't know what's happening, because the video plays on the IE and plays too on Google Chrome.

Can someone help me, please?

B
2
Posts: 1
Reputation: 352

Post » Tue Dec 18, 2012 12:25 am

@gblima

Humm... I guess... maybe the format of video. Are you useing "mp4" video? You might provide another video format like "webM" or "ogg" for firefox.

B
97
S
22
G
176
Posts: 4,109
Reputation: 103,021

Post » Thu Dec 27, 2012 7:04 pm

Is there a way to reverse play the video? Something such as reverse = true/false and it starts at the last time elements and works back to 0?

Thanks.

Draco
B
3
Posts: 2
Reputation: 649

Post » Fri Dec 28, 2012 3:16 am

@dracogriff

I though the video tag of html5 did not support this feature. (Am I right, @Pode ?)
B
97
S
22
G
176
Posts: 4,109
Reputation: 103,021

Post » Fri Dec 28, 2012 9:26 pm

@rexrainbow : the HTML5 video tag allows it, but it depends on the browser, the OS and the codec. Since most video codec are designed to stream a few block of images, display them, and do that chunk after chunk. That means that depending of the combination of sources listed above, the display can be choppy, or even not working at all.
B
33
S
9
G
6
Posts: 709
Reputation: 6,704

Post » Wed Jan 09, 2013 7:00 am

Is there anyway I can play the video behind sprites? i mean it does not follow the layering it's always at the top even though it's layer is at the bottom.
B
3
Posts: 1
Reputation: 581

Post » Wed Jan 09, 2013 9:36 am

@snapworxdigital : the video frame is overlayed on top of the game canvas. It wouldn't be wise to paint the video inside the canvas without getting a hit on the performances...
B
33
S
9
G
6
Posts: 709
Reputation: 6,704

Post » Thu Mar 07, 2013 9:06 pm

[QUOTE=Pode] @RoSecco @rexrainbow : on ipad/iphone (ios in general), the <video> can't work like that. In fact, if you want to launch a video, it's going to display in fullscreen, with the controls of the platform (meaning you can't style them, you can't autoplay the video, and you don't have any info about when it's finished).[/QUOTE]

Does this mean you cant use the "on ended" event?

I'm also having problems using this plugin when building an Android app. I found a post saying that the video tag is basically broken on Android. But there is a solution here, is it posible to combine/implement this in the plugin?

Or another workaround?
B
3
Posts: 5
Reputation: 585

PreviousNext

Return to Completed Addons

Who is online

Users browsing this forum: dark1994 and 2 guests