[Plugin] Windows Phone Updated - New Tutorial!

Post your completed addons to share with the community

Post » Thu Mar 27, 2014 6:18 pm

thehen wrote:@humanescape PM me a build and I'll take a look. If the back button doesn't work it's 90% likely that the files haven't been copied across to the supplied project properly as per the tutorial.



thanks but I figured it out. Turns out your download contains multiple copies of your plugin and project. I used the wrong one xD
B
31
S
12
G
7
Posts: 415
Reputation: 6,870

Post » Wed Apr 02, 2014 1:22 pm

@thehen
After setting everything up, I must say the performance is great considering the lack of WebGL.

I do have some problems though.
First, when specific events trigger during game play, the framerate drops to 0 for half a second or so. This happens randomly, one in every 10 times one of the events get triggered. Note that this does not happen on the regular windows phone 8 export.

Second, at a different event at the end of the level, when I spawn three stars and "drop" them on the screen, there's a chance that the game would freeze and I'd have to leave and get back in to the game for it to continue from where it froze. Again, this does not occur when using the default c2 wp8 export.

Anyone experienced similar issues? (Tested on Lumia 1020)

EDIT:

Oh, and I forgot, is it me or is the tag option missing on the play music event?

Image
B
33
S
12
G
7
Posts: 227
Reputation: 7,582

Post » Thu Apr 03, 2014 2:20 pm

@thehen

any chance for an email action?
B
31
S
12
G
7
Posts: 415
Reputation: 6,870

Post » Thu Apr 03, 2014 9:25 pm

@KFC weird, can you try removing all audio actions and rexporting to see it is causing random slowdown.

I'll need some sort of repro for the freezing too.

Tagging music isn't supported as it uses the phones media player, which can only play one piece of music at once. Just use sounds if you need tagging functionality.
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Fri Apr 04, 2014 2:46 pm

It appears both were caused by the game trying to play the sounds with the audio plugin, thanks.

It says "tag" at the end of the Play Music event in the event sheet so I thought I was missing something regarding tagging music.
Image
B
33
S
12
G
7
Posts: 227
Reputation: 7,582

Post » Mon Apr 07, 2014 2:18 pm

@KFC ah looks like a bug my end :)
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Wed Apr 16, 2014 1:24 pm

does anyone know if the back button requirement is changing at all with windows phone 8.1?
B
57
S
10
G
6
Posts: 455
Reputation: 8,530

Post » Thu Apr 17, 2014 12:43 pm

I can't seem to be able to use the on back button condition anymore. Neither with the browser nor this plugin.
B
46
S
17
G
18
Posts: 847
Reputation: 13,802

Post » Fri Apr 18, 2014 2:39 am

I'm having two issues at the moment with the Plugin (which is fantastic btw!).

For one, like a few others, I cannot seem to use the back button at all (my phone is a Lumia 920 with Windows Phone 8.1, and hitting back in the app does nothing).

And two, I can't find a way to control the volume of my sounds. For this project, I need sounds to fade in and fade out. To do so, I have be doing simple Construct loops (For example: if audio volume < 0, set volume = volume +0.5). This works fine on Android. However, with the plugin, I'm assuming none of the default audio controls work, so my audio "set volume" action doesn't work. And the Windows Phone plugin object doesn't have any volume controls in it. Any idea how I can get this to work, or am I SOL on Windows Phone?

Andy
B
5
Posts: 21
Reputation: 267

Post » Fri Apr 18, 2014 9:40 am

@hotcakes if you can PM me a build I'll look into the back button. Are you definitely copying the correct files into the directory provided as per the tutorial?

You can set volume using the WP plugin, and you can store the volume as a global variable.
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

PreviousNext

Return to Completed Addons

Who is online

Users browsing this forum: No registered users and 3 guests